Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
thereza

Crazy print..

Recommended Posts

WIth the routine I wrote down in the post I had print a simple cube. from now on I continue to try and try and try again tweaking profiles.

The paramenters in netfabb are really powerful and you have to tweak them one at a time to understand the effect.

first: the original material profile doesn't work good for me and my silver PLA. I NEED a temp of about 210-220 C° to print.

2. the distance between extrusor head and base is fundamental and you have to check it AFTER you put the blue tape on it. I use a simple paper strip and adjust the screws in the for corners again and again to level it and after that I had to move the screws again to LOWER or RAISE the bed and to make the PLA stitch on it.

3. rub the blue tape (better if you use orthogonal layers of blue tape) with alcool to remove the wax from the tape and make it sticky for the hot pla (this works a lot and it is hard to dtach the printed piece after)

4.turn off the fan for the first layers. if I don't do that the PLA won't stick good for the first layers. (after a lot of time on netfabb I made a profile with 2 regions, a <10 layer and a >10layer with the fan off and on, and it works...sometimes...)

5.netfabb sometimes act weird. I mean a lot weird. if I disconnect and reconnect the UM sometimes netfabb starts to move the extruder backward and remove the filament from the head... sometimes it seems to print in double dimension and half the speed, sometimens simply doesn't give any feedback on my commands...

6. start with a STANDARD profile. the standard material (0.150 layers) with the standard profile work quite good and is already a wonderful quality.

about your picture, it has a lot of stringing, I think it depends on the FINE extrusion (very little pla extruded) with the fan on. it freeze the pla filament as soon as it exit the head. I'm a newbie too but it seems that the your extruder is too low on your bed ( I can be wrong).

I printed several 'things' like yours, I noted that when the head is too low it melt the previous layer and start to make strings and little blobs of pla aroudn the nozzle that detach after a while and ruins the print.

anyway, printing like the good pictures showed by the masters on the forum is really a pain in the ...

Share this post


Link to post
Share on other sites

You have too little plastic coming out, this could also be a mechanical problem in the extruder drive mechanism. Make sure the big gear is firmly attached to the bolt, I know mine was slipping at first which caused a lot of headache.

Share this post


Link to post
Share on other sites

I'm pretty sure it's either a temperature problem or the bolt not being tight enough.

Netfabb tries to print on very low print temperatures. This has some advantages but also some downsides.

I suggest you try to get the temperature up. On High quality setting generally 225 degrees is a good start. You can go down from there if you have a lot of stringing. There's no such thing as a best temperature. It depends in your PLA/ ABS and also varies per color and layer thickness.

My white PLA from Ultimaker uses the highest temperatures to print @ 220-225 at standard quality, probably 5 degrees lower for high quality settings and 10 degrees lower for Ultra prints.

I'll look into the temperatures first since I think that is the most obvious reason to loose extrusion.

Also check the bolt on the extruder gear part which puts pressure on the material. It should be really tight!

Hope this helps,

Michael

Share this post


Link to post
Share on other sites

I keep getting erratic behavior when printing from netfabb. However, I tried out Cura/PrintRun and it worked significantly better..

5a330c97f2878_JonathanBrand3DPrintedMotorcycle6.thumb.jpg.58a86431aed246b821d2916d3aa85b7e.jpg

It's not perfect, but I it's night-and-day better. Why is the free software working better than the commercial software? I'm tempted to ask for a refund unless they want to fix their application.

Reza

Share this post


Link to post
Share on other sites

After another day of tweaking NF with small results I started to use cura/PR instead. Netfabb has an erratic behaviour, something print good, the next time it doesn' work a all ( i.e. The extruder start spinning backward fast retracting the filament, or go to home position again and again...)

My attempts with cura and pr ( after a simple calibration of the E steps =925) went very good and i coild print several real objects yesterday and not only calibration cubes... ( still my 3d preview window doesn't work but all the rest works great)

I can print again and again with no problem at all. My only problem now is How to detach the printed piece from the bed? It stictch so well that every print I must change the blue tape... But I am smiling a lot now!

I know we all 3d printers are like pioneers but : why a free ( and very well supported, great work Daid!) software is better than a 150 bucks software???

Yes I printed with nf last days but everytime I must keep my fingers crossed.... And that' s not the way.

i really hope that nf team starts a deep review of their software and release a STABLE version with some new feature asap, meanwhile cura is the way to go. Just my 2 cents.

For new UM buyers, think well before buying nf, maybe it's better wait for the next version and buy now 150 € of PLA instead, you will use it with cura...

Edit: just opened a support ticket to nf...waiting for their reply

Share this post


Link to post
Share on other sites

Have you tried exporting the gcode from Netfabb and printing with Printrun instead? Printing directly from Netfabb has never actually worked as it should as far as I know (which is pretty pathetic considering the price IMHO). Also, since Netfabb still isn't volumetric you probably need to calibrate it a bit for your specific PLA to get it working as it should:

http://wiki.ultimaker.com/NetFabb_Setup ... alibration

Or, you can give ddurant's program a try. People seem to be having good luck with it. I've only tried it once real quick and it was over extruding quite heavily, haven't had the time to sit down with it and fix that yet but I'm sure it's fixable:

viewtopic.php?f=9&t=194

Share this post


Link to post
Share on other sites

I print all my things with gcode generated by Netfabb and I think it's brilliant. I save the gcode Netfabb makes, open it in RepG26 and start printing. It gives me some nice results and quality so far. My main challenge was to get the first layer right...

Calibration? I honestly feel there's no need for that.

Volumetric? Don't even know exactly what it means. Don't really miss it with standard Netfabb.

Direct connection from Netfabb? Working, still not great.

Cura probably better? I have no idea since I had some trouble installing Cura. Daid helped me right away pointing me towards a Windows 7 administration issue. Due to the good experiences so far I'll have a look into Cura again.

Besides: Daid does a very good job in developing Cura and giving people good support for it! It's something Netfabb can learn from.

Share this post


Link to post
Share on other sites
I know we all 3d printers are like pioneers but : why a free ( and very well supported, great work Daid!) software is better than a 150 bucks software???
Cura rides on top of the free open source Skeinforge, which has years of development. It's a simple result of collective minds making great things. I'm not a huge advocate of OpenSource, but in this case it seems to work.

Note, when the Ultimaker was released, the state of Skeinforge was a lot worse, and NF was a pretty good alternative.

I think I've fixed the Administrator issues for the RC2 release. I hope to get it released before Monday so I can show it off at the Ulti-evening.

Share this post


Link to post
Share on other sites

Which firmware are you using?

Make sure you're using Marlin.

I have Netfabb working and I'm totally in love with it, the only tweaks I did to it were to change the raft creation speed from 8 to 40 and I increased the temperature by 10 degrees.

Now and then you have to check the feeder motor to make sure it's extruding correctly.

Apart from this select the following:

1- make sure you do outline before you print in netfabb (don't use RAFT, shouldn't be needed)

2- select PLA Ultra in the extruder material

3- select 2-High Definition Pla (not ultra) - filled object in the slicing properties and make sure the spacing is set to 0mm

4- try with a test cube first and then move to something else more complicate, it's all part of a learning curve :)

Try this way and post a pic of the result :)

Share this post


Link to post
Share on other sites

just started a jodalite with yur advised parameteres. first 4 layers are outstanding. first layer went great, well stitched on the bed.

to be continued...

edit:

9% build

finished downskin in a perfect way, the inside fill ( I went for 2.0mm and not 0) is very good. the skin is fantastic, I can't see the layers. At the moment I' am very surprised and I'm swallowing to see it finished. at the same time I wonder where is the magic? standard PLA- standard filled object parameters gave nothing comparable with this but only problem...

to be continued

edit:

27%

all is going very well, awesome skin, perfect filling, no sign of detachment from bed, temp 195, no leakings... cross my fingers...

edit:

65%

I'm totally wiped out... this is the Ultimaker I bought! printing at 0.08, no support (I'm at yoda's ears level), no stringing, no blobs, no visible layers. I don't understand WHY nobody wrote before how to use netfabb? It's incredible that the basic standard profiles give erratic behaviour and the ULTRA & High quality profiles give a fantastic result without any problem.

Share this post


Link to post
Share on other sites

@goodwill I didn't have that, but someone told me to put M92 E14 in there. You're the first person who mentioned E30. Why isn't this documented someplace? It's so frustrating. This is what I now have -- and i realize I have 2 E92 commands, but the second should override the first - and I'm leaving it as a reminder.

M106

M109

M92 E14

M92 E30

G92 E0

@daid I found a bug in cura and submitted a ticket. The configuration wizard requires a preferences.ini file to exist with a default steps_per_e else it doesn't work. The RC1 install doesn't include one (probably so as not to overwrite the old config) which means it defaults to 0 and a couple calculations fail and the extruder doesn't extrude.

I'll play around some more today and post the results..

Share this post


Link to post
Share on other sites

just finished the yoda lite print with ULTRA PLA and HIG QUALITY profiles (the original ones in Netfabb engine for Ultimaker).

A W E S O M E !

the quality we all are looking for and we all admire in some of the best picture around the forums.

a lot of time (about 4 hours) but a 0.08 mm layer thickness and a fantastic result. hope to post the picture soon.

thanks for the advice to Antiklesys. I have to rethink about Netfabb 4.9... try it.

Share this post


Link to post
Share on other sites

Ugh.. I followed all the instructions and I'm still failing. I tried the yoda at 1/4th size so it wouldn't take forever. At first, it looked good - especially the back, but by the time I got to the head it went bad.

I found my initial problem was due to the head being too close to the surface (I thought that's what you wanted) but I raised it a bit and it helped. But not for long..

For the outside, I would get these blobs that form - if anything, I would imagine overextrusion(?) I also got some stringing but not nearly as much as with the standard profile. It seems that these blobs are biggest problem. Odd thing is that some parts (like eyes) printed out great.. It's a bit odd

So what should be in the header G92 E14 or E30?

CE Declaration of Conformity Ultimaker 2.pdf

5a330c99793e9_IMG_1056kopie2.thumb.JPG.1e0886983ad6c708af744ea529e88199.JPG

Schermafbeelding_2014-10-10_om_23_01_16.thumb.png.2dbe8ec422bc35889cafcccd250a9d26.png

Share this post


Link to post
Share on other sites

@ Italianmaxx :Thank you for your feedback, you made my day :D

@ Thereza :Leave the header of the Gcode as it is by default in Netfabb, In your case thereza try again with PLA ULTRA in the materials but don't increase the temperature as I suggested to do and leave it the default one in netfabb. It will reduce a bit the blobs.

Also make sure the Z axis is goes to 0 correctly.

To do this go in Replicator G and open the control panel and move the Z axis by 0.1 mm up and down and make sure it's 0 when it touches the plane. Also make sure the bed is leveled properly and that it touches the plane uniformly in every corner.

Always do the 0.1mm up and down thing as in some corner the plane might be higher and push too much towards the nozzle.

Double check this and let me know.

@ Italianmaxx : I'm glad my help was useful for you :) Post a couple of pictures of your print as you made me curious :)

@ Both of you : Ultimaker also makes better prints when you print improvement parts. If you guys want I can suggest you a couple of modifications you can print in order to improve your prints.

Also remember that each color of PLA extrudes at a different temperature so you might have to play with it...and clean the feeder screw now and then :)

EDIT: it also happens to get some blobs when you're doing yoda's ears. This is because of the "jumps" the machine does between the head and the ears (you can see the jumps in red in the slicing done by netfabb). There's no big deal with them apart of cutting them after the print is done. If you still get too many, check the temperature again as said before :)

Share this post


Link to post
Share on other sites

here my results with the parameters advised

IMG205

p.s. how to put photos directly on post? I use flicker

@antiklesys

can you share some other combination of material/profiles that you use. I need to print in lesser quality but faster. the standard quality profile seems not so good. an of course, let us know which modification you did to your UM to upgrade it!

thx!

:D

Share this post


Link to post
Share on other sites

Hi italianmaxx, the link to your pictures isn't working well on the forums but I've managed to retrieve it :) Good job!

I did the following modifications to my Ultimaker:

http://www.thingiverse.com/thing:10082

- belt tensioner (using them just on 2 belts)

http://www.thingiverse.com/thing:10501

- this is an improved fan shroud

http://www.thingiverse.com/thing:11864

- this one prevents the material from needing too much force to be extruded

http://www.thingiverse.com/thing:20930

- this one is a fix I developed for the previous mod :p

At the moment I'm printing this one:

http://www.thingiverse.com/thing:8903

 

And I will be installing this one during the next couple of weeks:

http://www.thingiverse.com/thing:15897

-this one is much as of an optional, but I've found that the regular one works pretty well if kept clean

I will soon develop my own "Ultimaker" feeder mechanism mod once I will have some spare time to project and design it :)

To increase the printing speed I would have Netfabb to slice the piece as you do right now, then save the generated g-code and load it in ReplicatorG.

Use the manual controls in ReplicatorG to home all the axes and pre-heat the machine, then load the g-code in it and start the print. Use the live tuning to go up to 250% speed. This way you will get an almost high quality print but in less time.

When I want to do fast low quality prints I usually use ReplicatorG as slicer for the g-code, but the results aren't impressive. If you want to use Netfabb you can try increasing the temperature by 20-25 degrees in the standard pla in the extruder materials and change the raft speed to 40 from 8 (as you did for the other one, but this time we'll be using a higher temperature). Still select the outline before slicing the piece and see how it goes.

In Netfabb I also modified the following in the machine setting, changing the g-code header from:

M106

M109

 

to:

M106

M109

G90

G92 X0 Y0 Z0 E0

G91

G1 Z35.0 F400

G92 E0

G1 E260 F1000

G1 E-20 F3000

G92 E0

G1 Z-1.0 F100

G1 Z-34.0 F400

G90

G1 Z0.4

G92 Z0.4 E0

This is to have a pre-extrusion before the print (stolen from ReplicatorG :p ), in order to clean the hot end properly. Check it out.

 

I have heard a lot of things about Cura and I want to check it out, but ....ironically..I haven't managed getting it to work :p I believe there's something in it's g-code headers that my Ultimaker doesn't like :p

Let me know how it goes:)

Share this post


Link to post
Share on other sites

Thanks for the suggestions. I'm beginning to suspect that my repair of the extruder nossle failed and it is still leaking some small amount of material which might be causing my problem. I suspect that if I attempt to repair it again, I'll break the brass tube. I've already emailed ultimaker about ordering spare parts but have not heard back.

So what was the original temperature in the netfab config? I've changed it a couple times and I don't know what the original value is.

And I tried the standard PLA profile again, and it just dumps out way too much plastic and it makes a huge mess and fails. Why is this considered a workable profile by others?

And finally, why isn't there a temperature for each type of plastic listed someplace. It would be nice for the mfg to list it or the ultimaker people to compile said list.

That being said, I'll try tightening the end nossle thing to see if that fixes my problem. I've already appllied teflon tape to no avail. *sigh*

@Antiklesys I'll probably print the fan shroud as the current one looks pretty ghetoo. Otherwise, my belts are tight already and I have no issues with the feeding system. Just the leaky extrusion nossle.

Share this post


Link to post
Share on other sites

G92 E14 if you are using the stock Ultimaker hobbed bolt extruder design.

I use G92 E14 with marlin firmware from Cura and it works.

Smaller prints are more challenging to get good quality, you should try Yoda-Lite at full size with the ultra profile. I seem to remember it took 4.5 hours. I set mine up before bed and watch it for the first few layers to make sure I've got a good start. Make sure it's stuck to the bed, and if you've had any problems with the extruder slipping, clean the hobbed bolt.

You will get some stringing between the head and ears, and the top of the head on mine didn't completely fill, but it still looks great.

Kyle

Share this post


Link to post
Share on other sites

Hi thereza,

I used to have the leaking problem too, but it only happened when I was printing at high temperatures (around 250 degrees). If you print at 180 to 190 degrees (default standard temperature for pla ultra in the ultimaker material settings) you shouldn't have any leakings.

I have noticed that the teflon tape melts too. So: yes it would solve the problem a bit...but it may be leaking out once melted if the bolt isn't tight enough. What I would do is to use this one ( I haven't done it but I would if I had your same problem):

http://www.ebay.co.uk/itm/290624636619? ... 1423.l2649

or any similar heath resistant glue. Make sure it resists to temperatures over 300 degrees tho, this one is good up to 400 so you should be fine.

I don't know if there's a temperature setting for each type of plastic somewhere. The main difference is between ABS and PLA, but as said before, there are slight temperature settings to take in account considering the color you're using. I guess it's try and fail every time you switch color. Usually everything should be fine between 195 and 215 degrees.

Share this post


Link to post
Share on other sites

@ thereza

here are the material settings:

011-MakerfaireNYC14_kopie.thumb.jpg.1a4fa140bb821b5063644b8716089b94.jpg

Strange that your amount of plastic is way out..

This must be a combination of firmware and specific settings, I guess...

why else would it work for one and not for the other?

the thing that did it for me was the M92 E14,

before my prints looked like yours in the first picture...

and the upgrade to a better marlin:

https://github.com/ErikZalm/Marlin

at the bottom of the page the explanation how to install, with the Arduino software

Cura is too difficult (for me anyway..) to install on a mac.

I like netfabb as a slicer, the best setting with an amazing result, I found was to change the settings (standard) for the layer type Outer and Inner1.

Set both to every half layer with speed snake.

that is probably close to the ultra settings, but if you use another quality, set both to: every half layer.

the difference was huge!

IMG_1047_kopie.thumb.JPG.7fe8a97ba934deaf41ab9ca7afba9887.JPG

Now I hope that someone else can reproduce this!

IMG_1021_kopie.thumb.JPG.70f4742a131625826bd48fbd9560c1be.JPG

Share this post


Link to post
Share on other sites

almost nothing...

on the top only some very thin threads

In the drawing I put some support underneath that had to be removed.

The little discs on the corners are to prevent it from curling up,

a tip I read in an earlier post.... :D

IMG_1013_kopie.thumb.JPG.e18bd29596fe6dc1776fbee481c00cf0.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 0 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!