Jump to content

Need help with the default home position in the Z axis


Recommended Posts

Posted · Need help with the default home position in the Z axis

I am using a davinci mini w+ (unfortunately) and the home position inside of cura sends it to the bottom of the gantry, im concerned it will crash into my prints upon completion as in the XYZ software the home position is at the top of the gantry. How can I manage the default home position (G28) or make it so it doesnt go to this position? Im pretty new to this and im sure the answer is out there I just couldnt understand it and google gave me the same irrelevant results no matter what I searched. please explain it like im 5 

  • Link to post
    Share on other sites

    Posted · Need help with the default home position in the Z axis

    Homing is carried out by a command in the StartUp Gcode.  Some printer definitions contain a homing command in the Ending Gcode as well.  Not a good idea.

     

    In Cura go to "Manage Printers", "Machine Settings".  In the lower right text box will be the Ending Gcode.

     

    The commands should lift the nozzle slightly from the print, then park the print head at the back (move the build plate forward) and shut down the heaters and XYE steppers.  The Z stepper is usually left engaged so the print head doesn't drift downward by itself.

    This is my Ending Gcode.  You can see there is no G28 but rather "relative" moves that get the print head up over the print, then parks it at "{machine_depth}" which Cura will replace with the number you have in your machine settings for the build plate size.  You can see that the only Z moves are upward so there isn't any chance of crashing the print.

    If you have a direct drive extruder you would want to touch up the retraction distances in this.

     

    G91 ; Relative positioning

    M83 ; Relative Extrusion

    G1 E-2 F2700 ; Retract a bit

    G1 E-2 Z0.2 F2400 ; Retract and raise Z

    G0 X5 Y5 F3000 ; Wipe out

    G0 Z10 ; Raise Z more

    G90 ; Absolute positioning

    M82 ; Absolute Extrusion

    M220 S100 ; Reset FeedRate

    M221 S100 ; Reset FlowRate

    G0 X0 Y{machine_depth} ; Present print

    M106 S0 ; Turn-off fan

    M104 S0 ; Turn-off hotend

    M140 S0 ; Turn-off bed

    M84 X Y E ; Disable all steppers but Z

     

    If you currently have a G28 in your Ending Gcode changing it to "G28 X Y" will keep it from homing the Z.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.8 beta released
        Another Cura release has arrived and in this 5.8 beta release, the focus is on improving Z seams, as well as completing support for the full Method series of printers by introducing a profile for the UltiMaker Method.
          • Like
        • 1 reply
      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
    ×
    ×
    • Create New...