Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
silvio-tidu

x and y axes trouble, head not homing

Recommended Posts

Hi there,

I've a big trouble with my new UM2 arrived today.

it's really sad that it has not even been able to print my first robot :angry:

 

I follow the manual but from the "first time startup" the head seems to go in the wrong way, probably don't recognize the home position.

I tried to reset all and reinstall the firmware but the problem occurs again.

 

I also checked the switches and seems to click well

See the video to understand better.

 

 

Any suggestion?

Silvio

 

Share this post


Link to post
Share on other sites

We really need to see the video. Please make it public!

There are 3 possible things that make an axis go the wrong way.

1) Either a limit switch is stuck,

2) the DIR signal is stuck, or

3) the stepper motor connector is wired backwards.

#3 seems unlikely because that would have been caught at the factory. #1 is most likely but you say you tested it.

X *and* Y axis not homing? This is very strange. How could both break during shipping at the same time?

Need to see the video.

 

Share this post


Link to post
Share on other sites

Looks like the limit switch(es) isn't engaging. Try moving the head out of the corner by hand (you might have to turn the printer off so that the steppers release if they haven't already), then slowly slide it towards the left. Just before it hits the wall you should hear a soft *click* Repeat the same thing but this time slide the head to the back of the printer and listen for a click.

If you don't hear a click you'll have to adjust the limit switch so that it engages properly. For the left side it's the one to the right in this picture, at the back of the printer.

endstops

Loosen the two screws that hold it in place and try to slide it towards the right and then re-tighten. Repeat the test and see if it clicks. If it still doesn't you can try bending the metal tab a bit so that it engages sooner.

Try this first and see if that's the issue, if it's not we can talk about other things like checking if the cable is connected correctly and so on.

 

Share this post


Link to post
Share on other sites

Please push all 3 axis away from their extremes and try it again. With power off you can push the bed up and down but do it from the REAR of the bed - near the back of the machine - don't push up and down that hard on the front edge of the bed.

It definitely sounds like your X axis isn't hitting the limit switch but I'm confused about the Y axis - that should at least move to the rear.

 

Share this post


Link to post
Share on other sites

Looks like it succeeds in homing the X-axis (left and right) but something is mechanically stopping it from moving in the Y (backwards and forwards). When you move the head around with the power off I'm assuming it is much harder to move it to and away from you as compared to moving it left and right?

It could be a few reasons for this but unfortunately I have to run out so I can't go into detail right now. I'm suspecting that the thinner rods are not perfectly square which is causing the head to jam.

It could also be that something is rubbing and causing friction such as the pulleys on the motors.

Gah, have to run. Sorry!

 

Share this post


Link to post
Share on other sites

Good news. X and Z axis seem fine. It is the Y axis. There could be a few things.

1) With power off, push head back and forth in X and Y axes. Is there a difference (thinking very high friction).

2) Look at the Y stepper and the Y belt. I think maybe the motor is turning but not the belt. The stepper motor is in the left rear corner. There are 6 pulleys that could be the problem. Each pulley has a belt around the pulley. There are 3 belts used in the Y axis - the short belt that goes to the motor and the 2 long belts. One of the set screws in the 6 pulleys is probably loose. Probably the one on the motor. You might want to remove the cover on the back left corner. The white metal cover is easy to remove and comes off with a single screw. Then you need to locate an allen wrench or torx screwdriver that fits these 6 pulleys. Push the head around and see which pulley(s) are loose and tighten the hell out of them. You want it so tight the screwdriver or allen wrench twists quite a bit but not so tight you break the screwdriver/wrench.

3) The Y limit switch might be tripping but I really doubt it because it woudn't make any sound. I hear a stepper moving but I don't see the head moving - I think it's problem #1 or #2.

 

Share this post


Link to post
Share on other sites

Did you try moving the print head by hand like both me and gr5 asked? This will help to diagnose where the friction is coming from. You might be able to feel scraping, hear some squeaking, notice that it can move if you jiggle something around etc etc. It seems the motor is trying to turn but it's being stopped by something mechanically.

 

Share this post


Link to post
Share on other sites

This is a problem I've never seen. And I've seen a LOT of problems. I have 3 theories:

1) something is stuck. This is obvious if you cut power and push the head around - X and Y movement should feel about the same.

2) Stepper motor or cables

3) Stepper driver

If you eliminate #1 then I would swap x,y steppers to see what happens. First get pronterface here:

http://koti.kapsi.fi/~kliment/printrun/

 

Connect to UM2 with USB cable, connect with pronterface and practice moving the good axis with G1 commands like this:

G1 X20

G1 X30

That moves the X axis to position 20mm and then 30mm. You can move to roughly 0mm to 225mm.

You can do X or Z axes and you can combine:

G1 X10 Y10 Z10

Now play with X and Y axes and if both are fine then your problem is BIZZARRE. If the Y axis is still messed up then cut power to the UM2 and remove the larger of the 2 bottom covers (only 2 screws - very easy) and then swap the X and Y servos. Then power back on. Reconnect with pronterface and repeat movements.

If the problem moves such that now the test head moves the other directoin (but same G1 command axis) then the problem is with the white contoller board and you should get another form support.ultimaker.com.

If the problem moves to the other axis in pronterface (but same servo) then the problem is with the servo or wiring. It's possible that one of the 4 wires is broken, but just order another servo if you narrow it down this far.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

[[Template core/front/global/_customFooter does not exist. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!