Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
restinpieces

I don't get the fan settings

Recommended Posts

Hi guys

I tired to figure out how the fans works, but I'm still scratching my head.

Here are all the settings I know that affect fan speed. Maybe I missed one or maybe I don't understand them.

Fan full on at height: 0,4mm

Fan speed min: 20%

Fan speed max: 100%

I check at 2/3 print time and the fans are running at 11% speed I mean wtf :?: :?: :?: and they stayed there for a good while. They did not seem to be in some kind of ramp.

 

Share this post


Link to post
Share on other sites

Aaron means the "TUNE" menu.

By layer height .4mm I guess the fan should be at 20%. I never have tried less than 1mm for full fan so maybe there is some kind of bug?

20% is kind of low - sometimes the fan won't come on until it hits 25 or 30% so I'm not sure why you want 20%. I recommend 100% for PLA. If fan min is 20% it should start at 0% first layer and hit 20% by layer .4. It only goes to 100% if it can't meet the minimum layer time.

If you set fan speed in TUNE menu this overrides the fan speed from the gcode (at least until the next gcode changes it again but once at 20% it might stay there for the whole print).

 

Share this post


Link to post
Share on other sites

Yeah, my response is a little vague; I meant once the print started, within the tune menu. Also, a couple of other things; within the last two official Cura releases I've set the fans to kick on from 0.2 - 0.5 mm without any issue; and if you physically watch the fans you will see them kick on much higher than 20% to overcome the blade inertia and then they will quickly settle back to the 20% speed value.

 

Share this post


Link to post
Share on other sites

Thanks for the replies. I did not mess with the tune menu other then look at the current fan speed, it was able to change.

I thought I had it after your replies and tried these settings:

Fan full on at height: 2mm

Fan speed min: 60%

Fan speed max: 100%

What I expected:

Fan is off until 2mm

at 2mm it starts with 60% and stays there until the print forces slower move speeds.

When the movement drops the fan speed rises up to 100% depending on the movement.

Unfortunately I was to busy to make a protocol but what I saw was, that well above 2mm the fan speed was 34% and until the end of the print it never reached 60%

So, I'm still confused like heck

 

Share this post


Link to post
Share on other sites

Ans another observation. when the print comes to the part where there is less material and therefor the time in one level is shorter the fan slows down. I had it manually set to 60% and in smaller levels it slowed down to 43%. Thats totally the opposit of what it describes in the tool tip and what I would expect.

 

Share this post


Link to post
Share on other sites

Sitting by the printer and watching it change is a lot of wasted time. Instead look at the gcode. Gcode is easy to read - it's meant to be read by computers *and* humans. It has lots of comments about layer number in there and so on. The fan command is M106. The "S" number after that is the speed where 0 is 0% and 255 is 100%.

While in the TUNE menu and looking at the fan speed maybe it's possible it won't change?

More likely I think you found some bug. I never set min fan speed to anything other than 100% because I don't print ABS much but maybe you found a bug.

What it should have done instead is start off like you said but turn on GRADUALLY until by layer 2mm it is at 60%. 34% maybe around layer 1.2mm and it might have been stuck because that's when you entered fan menu settings within the tune menu? And that action may have locked the speed. Check the gcode - it's much easier. Search for M109 and you can see right there what layer it is modifying fan speeds on in the comments.

 

Share this post


Link to post
Share on other sites

Unfortunately I was to busy to make a protocol but what I saw was, that well above 2mm the fan speed was 34% and until the end of the print it never reached 60%

I've found that the firmware scales the values set by Cura (in the gcode) by the setting in the material properties, so if the setting Material->Settings->Customize->Fan Speed is 57%, it will produce the behaviour you saw.

 

Share this post


Link to post
Share on other sites

so if the setting Material->Settings->Customize->Fan Speed is 57%, it will produce the behaviour you saw.

Interesting! I didn't know this but it makes sense. I think you meant 72% (72*.6 = 43)

 

Share this post


Link to post
Share on other sites

Alright, thx guys for the input. It took me a while to get back on the topic.

Here is what I did.

I made a test model and analyzed the gcode

The model has a 10mm section which has a layer time >5s so it should not be slowed down. Above this section is a section which gets smaller so somewhere in there the minimum layer time of 5s should be undercut.

I made a calc sheet to analyze the G-code. And from the G-code it seems all ok to me. There is the first section which ramps up to 60% and there is the last section where the Fan almost reaches 100% because the layer time is lower then 5s ( I assumed 256 in value should be 100% fan speed)

So while everything seems fine with the gcode I'm back to checking the fan settings while its running. The 35% which I get on the UM2 screen might be, as u said cyan, the 60% from material setting multiplied by the 60% from the fan setting. But that still does not explain why the fan got slowed down during the parts where layer time was <5s.

Fantest1

Fantest2

Fantest3

 

Share this post


Link to post
Share on other sites

Nice excel graph. It would be interesting to also include layer time - Cura simply assumes 100% acceleration and determines it based on print speed and total length of all lines on a layer.

Again: Did you hover over the settings in Cura? It explains how this works.

Again: For PLA you should be using 100% fan for min and max. For ABS, lower fan speeds make more sense.

To answer your question - if you hover over the "max" fan speed it says it increases fan speed to MAX value as layer time adjust speed by 200%. I think Daid means 50%. So the point is that as print speed approaches half of nominal speed, fan speed should approach MAX speed.

You could test this by starting the print with a higher print speed and then graphing it in excel again.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!