Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
kwatts

switched to cura for first print

Recommended Posts

Hey guys,

So based on the response from my last post:

viewtopic.php?f=21&t=784

i switched to cura.

Previously i got to the print stage, after configuuring the end stops and extruding some plastic.

But with cura, i cannot get past the ultimaker checkup.

It fails on:

"Error: Missing reply to Deactivate steppers (M84)."

"Possible cause: Temperature MIN/MAX.\n Check temperature sensor connections."

I have turned off the machine a few times now and checked all the connections to the electronics , with no luck of getting past this problem.

I saw in the out put that i was getting a None type return so , i added some debug prints that im hoping might help for getting a solution to this:

Connecting to: COM5 250000

DoCommCommandAndWaitForReply:cmd None

DoCommCommandAndWaitForReply:replyStart start

line: start

DoCommCommandAndWaitForReply:cmd M84

DoCommCommandAndWaitForReply:replyStart ok

line: echo: External Reset

line: Marlin: 1.0.0 RC2

line: echo: Last Updated: Marlin-Thu, 12 Apr 2012 14:01:30 +0200 - 414408b2d0fed428b55445f48b01d00932a7a92c | Author: Build-Me-Marlin

line: echo: Free Memory: 4498 PlannerBufferBytes: 1232

line: echo:Using Default settings:

line: echo:Steps per unit:

line: echo: M92 X78.74 Y78.74 Z533.33 E865.89

line: echo:Maximum feedrates (mm/s):

line: echo: M203 X250.00 Y250.00 Z5.00 E45.00

line: echo:Maximum Acceleration (mm/s2):

line: echo: M201 X9000 Y9000 Z100 E10000

line: echo:Acceleration: S=acceleration, T=retract acceleration

line: echo: M204 S3000.00 T3000.00

line: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), =maximum xY jerk (mm/s), Z=maximum Z jerk (mm/s)

line: echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00

line: echo:PID settings:

line: echo: M301 P22.20 I1.08 D114.00

line:

I am running on winxp 32, on a centrino duo chipset, with whopping 3.4gb of ram..

Please let me know if there is anything else i can provide to help figuring this out.

Cheers

kym

Share this post


Link to post
Share on other sites

Ok, so the question then becomes.

if i calibrated the machine and build platform in replicatorg 24 with the standard firmware.

now that im using cura, and updated to marlin, how do i re calibrate? or do i need to

i notice that cura doesnt have a control panel type thing that rep g has... soo?

Share this post


Link to post
Share on other sites

Calibration from RepG24/25 (old way) and Cura/RepG34 is very different. The new was is called "volumetric", but the default calibration from Cura will most likely produce very decent results.

For printing and directly controlling your machine you can use PrintRun, which is packaged with Cura (different start menu shortcut). It offers a lot more features then the very basic Cura printing interface.

EDIT: But lots of thanks for those debug messages. They confirm what I suspected. There should be a delay after recieving the "start" line, and sending the M84. Because the firmware might not be fully up and running (most likely due to SD card failing to initialize). As it should have replied "ok" after the PID settings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy