Jump to content
Ultimaker Community of 3D Printing Experts

Error:Temperature heated bed switched off. MAXTEMP triggered !!


Recommended Posts

Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

hello, yesterday i,ve updated the cura software from 14.03 to 14.07 on my windows pc and install also the newest marlin firmwire on the board.

when the update was done i get stuck in the error: Temperature heated bed switched off. MAXTEMP triggered !!

the only thing that my ultimaker original with board number 1.5.7 and self build heated bed do, when i switch the power on: is getting pressure for about 1 second on all the motors and after that loose it for 3 seconds and repeat that (loop)

before i drive the same hardware for 3 months with cura 14.03 an secondary marlin firmwire with no problems.

whats going wrong with the new software ?

 

 

 

crash report:

 

Recv: echo: M301 P22.20 I1.08 D114.00

Recv: Error:Temperature heated bed switched off. MAXTEMP triggered !!

Changing monitoring state from 'Detecting baudrate' to 'Error: Temperature heated bed switched off...'

Recv: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

Recv: echo:SD init fail

Recv: echo:Unknown command: "

Recv: ok

Recv: ok T:0.0 /0.0 B:0.0 /0.0 T0:0.0 /0.0 @:0 B@:0

Recv: start

Recv: echo:Marlin1.0.0

Recv: echo: Last Updated: May 23 2014 11:34:31 | Author: (David Braam)

Recv: Compiled: May 23 2014

Recv: echo: Free Memory: 3977 PlannerBufferBytes: 1232

Recv: echo:Hardcoded Default Settings Loaded

Recv: echo:Steps per unit:

Recv: echo: M92 X78.74 Y78.74 Z200.00 E836.00

Recv: echo:Maximum feedrates (mm/s):

Recv: echo: M203 X500.00 Y500.00 Z30.00 E25.00

Recv: echo:Maximum Acceleration (mm/s2):

Recv: echo: M201 X9000 Y9000 Z100 E10000

Recv: echo:Acceleration: S=acceleration, T=retract acceleration

Recv: echo: M204 S4000.00 T3000.00

Recv: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)

Recv: echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00

Recv: echo:Home offset (mm):

Recv: echo: M206 X0.00 Y0.00 Z0.00

Recv: echo:PID settings:

Recv: echo: M301 P22.20 I1.08 D114.00

Recv: Error:Temperature heated bed switched off. MAXTEMP triggered !!

Recv: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

 

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    http://umforum.ultimaker.com/index.php?/topic/6016-possible-problem-with-cura-beta-um1-heated-bed/

    Try flashing with your custom built firmware. When you select self built bed, Cura will flash a version of the firmware intended for the soon to be released heated bed kit from Ultimaker which used a different type of sensor for the bed temperature. This caused the firmware to flip out

    You will (probably) need to pull the arduino out and reflash using the Arduino IDE and your self built custom firmware if you can't do it in Cura.

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    howto build and load a custom firmwire

    visit the website http://marlinbuilder.robotfuzz.com/

    select your brand

    choose your options (100k is the number of resistance from your bed temperature sensor)

    the rest i dont change

    click build

    right click on the HEX file and choose save as

    open cura

    choose machine>install custom firmwire (and load HEX file)

    done

    this is what work for me good luck (please correct me when im wrong)

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    Hi All

    I thought to be smart the first time after I installed the my custom HBK and in Cura selected the option to install the “custom hbk firmware” (so I thought) that came with Cura 14.06. Ups.

    After initially showing the bed temperature etc. it shows a strange error message (MAXTEMP / Error, can't remember) on the UltiController and then hangs! So clearly the wrong firmware. No more connection anymore via computer / usb. Panic (a bit)! Also after restart, the UM hangs at the same point.

    Solution that worked for me (vs pulling your Arduino):

     

    1. disconnect your USB Cable, turn the UM off
    2. In Cura click "install default firmaware..." so the dialog appears "Please connect..." and only then connect the usb cable to the Arduino.
    3. As soon as the Arduino starts powered by USB (probably before initialising), it starts the firmware update from the computer
    4. after the update you should be ready to flash any other / custom firmware

     

    Hope that helps at least some of you with similar issues.

    Martin

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    Good info Martin, I couldn't find a way to recover from installing the wrong firmware that didn't require me to remove the arduino. It might have been the USB hub that I use.

    If it happens again, I'll try your sequence.

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    Same here..

    Upgraded to cura 14.07 and it instantly gave me a MXA TEMP BED error.

    So I went to http://marlinbuilder.robotfuzz.com/ and build my own hex file.

    Uploaded to the machine and now working fine!

    Thanks for all who replied here on this thread! You saved me a lot of trouble shooting!

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    Hello. I need your help!!! I also have error at the maximum temperature of the hot bed. I generated the code on the site http://marlinbuilder.robotfuzz.com/but I can not download the hex file. I have 10k thermistor.

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    The only 10k thermistor table that comes with Marlin is this one:

    https://github.com/ErikZalm/Marlin/blob/Marlin_v1/Marlin/thermistortables.h

     


    #if (THERMISTORHEATER_0 == 4) || (THERMISTORHEATER_1 == 4) || (THERMISTORHEATER_2 == 4) || (THERMISTORBED == 4) //10k thermistor
    const short temptable_4[][2] PROGMEM = {
    {1*OVERSAMPLENR, 430},
    {54*OVERSAMPLENR, 137},
    {107*OVERSAMPLENR, 107},
    {160*OVERSAMPLENR, 91},
    {213*OVERSAMPLENR, 80},
    {266*OVERSAMPLENR, 71},
    {319*OVERSAMPLENR, 64},
    {372*OVERSAMPLENR, 57},
    {425*OVERSAMPLENR, 51},
    {478*OVERSAMPLENR, 46},
    {531*OVERSAMPLENR, 41},
    {584*OVERSAMPLENR, 35},
    {637*OVERSAMPLENR, 30},
    {690*OVERSAMPLENR, 25},
    {743*OVERSAMPLENR, 20},
    {796*OVERSAMPLENR, 14},
    {849*OVERSAMPLENR, 7},
    {902*OVERSAMPLENR, 0},
    {955*OVERSAMPLENR, -11},
    {1008*OVERSAMPLENR, -35}
    };

    The number on the right is the temperature in C. So if room temperature is around 20C then you expect the ADC reading to be 743 (out of range of 0 to 1023 which corresponds to 0 to 5V) so that means you should have 5*743/1024 or about 3.5 volts yet it is reading 0 volts or 5 volts to get that error.

    Check your wiring with a volt meter. Did you install the 4.7k resistor? Is it the right resistance? The circuitry is very simple - it's just a 2 resistor circuit. Also known as a "resistor divider":

    http://en.wikipedia.org/wiki/Voltage_divider#Resistive_divider

    Where one resistor is at 4700 ohms and the other (the thermistor) roughly 1.9k at 20C.

    If you don't understand this and/or don't have a multimeter, find someone who does.

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    These numbers don't seem quite right to me. I suspect this table is meant to work with a 10k resistor instead of a 4.7k resistor.

    There are many 10k thermistors out there all with very different properties which mean each manufacturer would need a different table. Same thing is true of 100k thermistors. So I suggest you get only the recommended reprap 100k thermistors.

    Much more information here:

    http://reprap.org/wiki/Thermistor#RRRF_10K_Thermistor

     

  • Link to post
    Share on other sites
    Posted · Error:Temperature heated bed switched off. MAXTEMP triggered !!

    Thank you for your information, gr5! My heated bed temp sensor died and I am awaiting a resolution from support. In another thread, someone mentioned soldering in a 220ohm resistor and that got the machine to work again, but it didn't work for me. I figured something more serious was wrong. After finding out there are different valued thermistors used, I decided to connect a potentiometer to the bed and see if I could find a range that worked. Jackpot! :) a 120ohm resistor registers as 42c~43c and 138ohm as around 110c. I put a 120ohm in and printed up a small 8 minute object in ABS. Went into the tune menu during printing and just kind of guestimated turning the heat on/off by alternating the desired temp between 40~45. Will attach my Fluke's temp probe tomorrow to hopefully get closer approximation of the temp of the bed.

    I hope Ultimaker either sends me another thermistor for my U2 (or tells me the value I should have so I can buy a few from Digikey) or another heated build plate soon... but being able to print again is awesome!! Thanks again!

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
          • Like
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 4 replies
    ×
    ×
    • Create New...