Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
ianeagland

Cura issue for my setup (Or am I doing something wrong)

Recommended Posts

Hi

I have a small issue with Cura (or maybe its skeinforge).

Start G code does not come at the beginning of the file.

This always comes first:-

;TYPE:CUSTOM

M92 E865.888000

M109 S210.000000.

The problem I have is that I do not want heating at that point. I am trying to adopt something similar to this strategy:-

http://hydraraptor.blogspot.co.uk/2012/ ... start.html

I want to control initial heat up in start g code.

If it were M104 I could kill it in the first line of my start g code with M104 S0 but of course the M109 holds everything until you are up to temperature.

Is there a work around for this?

Share this post


Link to post
Share on other sites

Yes, you can!

In all versions, the M109 is not added if you set the temperature to 0 in Cura.

In RC3 you can add "tags" in the start/end code. If the {print_temperature} tag is found in the start code, then Cura won't add the M109 because it assumes you set the temperature in the start code yourself. The {print_temperature} tag is replaced with the configured temperature in Cura.

(If you do not want the M92, then you can set the steps-per-e to 0 in the preferences, this will remove that line)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy