Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
ice086

Large Object Stalls Cura

Recommended Posts

I am working on slicing a rather large complex object. It is an ODST helmet from the Halo series of games. The link to it can be seen below. I am attempting to print this helmet as a demo piece to show what my machine can do.

I am attempting to run it at 279mm tall on a very large delta printer. When I attempt to use the following settings for the object it almost completes but stalls out at about 90%. I can still use Cura but slicing has stopped. I am able to complete the slicing process when I use no Support but I cannot complete slicing when I use Support Touching Build Plate.

Cura Version: 14.07

Layer height 0.1mm

Infill: 0%

Wall thickness 2.0mm

Support: Touching Buildplate

No bottom layer (object is open on the underside)

I am doing the slicing on a rather robust gaming machine so processing and graphics power is not an issue. I know that the slice has stalled out because I follow its progress using the Slicing bar and by watching my the fluctuations in my CPU from task manager.

If anyone has any suggestions please let me know!

Link to helmet:

http://www.bluerealmstudios.com/2009/09/15/legacy-odst-helmet/

 

Share this post


Link to post
Share on other sites

Somehow it managed to slice it this time when I ran it but Python ran up to 367.6 MB. The previous times were along the same lines.

If it helps I can run it a few more times and record how much memory python uses when it stalls out compared to when it completes.

 

Share this post


Link to post
Share on other sites

Well, I was wondering if it was the python process getting out of memory (which happens around the 2.5GB mark, so you are not close to that)

But, support material is very CPU intensive right now, so it could be that it is working, but very slow.

 

Share this post


Link to post
Share on other sites

Thanks to some assistance from Ice086 I think I have a solution for this bug.

This bug prevents you from generating gcode files bigger then around 250MB, most likely this limit is only on Windows. I'm working on fixing this, as I've found a solution, but need to verify a lot of other code because of this.

 

Share this post


Link to post
Share on other sites

I encountered same issue when running Cura - it refused save .gcode anywhere (memory was about 600 megs I think). By luck I found out that in my case it agreed to finally save something when I tried to owerwrite some another already existing file. Thought that I say it if somebody encounters same problem.

 

Would be nice to know if your problem was solved by the 14.09.1-RC1

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 0 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!