Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
christopher-luy

Ultimaker Original with Heated Bed Kit- Z axis problem

Recommended Posts

I just installed the heated bed kit on my original Ultimaker and have an issue I can't solve. To start, my Ultimaker had been printing faithfully for over a year, this issue is new since the upgrade. Also, when I installed the new Z axis parts for the heated bed upgrade, I aligned the new linear bearings very carefullly. When the Z motor is not enabled, there is so little friction that the bed will coast down to the floor of the machine when the z motor is not enabled. So the problem is not related to an over current situation on a poorly setup Z bearings.

OK, so I can print and everything seems to work fine until the Z axis is left to sit for too long between movements. It is almost like there is a Z motor timeout if the Z axis does not get used for a certain amount of time? I noticed that during bed leveling, if I take too long turning screws, the Z motor will turn off and the bed will coast all the way down. I can deal with this, but now I find that during a print where there is a lot of infill and the Z axis is not incremented quick enough, the Z axis will shut off in the middle of the print causing the bed to coast down to the bottom of the machine.

On prints where the Z axis is incremented at least every minute or so, the z axis never turns off. On a large print where the Z axis is waiting for say 3 to 5 minutes for the layer to finish is when the problem arises.

ANY HELP is greatly appreciated,

THANKS, Chris.

 

Share this post


Link to post
Share on other sites

Wow! Nice catch. I will PM Daid although he will probably read this anyway. I think there is a simple flag in the Marlin build that sets the timeout for the axis steppers. I guess a quick fix would be to insert some Z moves (to the same point) inside the gcode. Someone could easily write a plugin to do that. But I think a proper fix should be to Marlin.

 

Share this post


Link to post
Share on other sites

I did a quick test to measure the Z axis 'timeout' problem while performing the "Bed Level" routine. The Z axis turns off exactly at the 1 minute mark after no z axis increments. I don't know if this 1 minute timeframe is also the same while performing an actual print, although it seems like it takes longer to for this to happen while doing an actual print. It could be that the timer is reset during printing of the current layer if there are movements that include a Z to the same current height(zero translation).

I think it looks like we are definitely dealing with a timer of some sort that disables the z after a period of no z commands. Why this changed with the heated bed upgrade could only be something with firmware change?

Thanks in advance for your help,

Chris

 

Share this post


Link to post
Share on other sites

Is there a way I can look at the "#define DISABLE_Z false" setting in my firmware? Is there a way to set and save it? Just to see if somehow it was enabled?

Last night I opened a print dialog box and sent a M85 S0 command to try disable the inactivity shutdown timer. I then closed the print box and went into the bed leveling wizard. The z axis still shut off after 1 exactly 1 minute. Not knowing if I was using the proper syntax, I repeated this using a M85 Z S0 but the problem still persists. Does a "M" command sent from the print dialog box still reside after the print box is closed? Or maybe I wasn't using the M code properly?

I really appreciate your help. I am not sure where to go next. Maybe revert to older firmware and see if it clears up and then try the new firmware again. At least then we know for sure it is happening due to the new firmware install?

Chris

 

Share this post


Link to post
Share on other sites

Why this changed with the heated bed upgrade could only be something with firmware change?

 

Well it's because your Z axis is so slippery. The axis of the UMO and UM2 don't have this issue. Mine is slippery also but not quite enough to fall without touching it lightly. I've printed dozens of things without this problem. Also I assume if I print something with small enough layers I wouldn't likely notice it either.

 

Share this post


Link to post
Share on other sites

Yes, I added a new machine in Cura as an Ultimaker original with heated bed upgrade selected and then flashed the firmware.

I don't think that the problem is that the bed can move so smoothly, or that it should stay in place during a z axis disable. If this was the case, then regardless of weather or not the bed did move when the z motor disabled, the print would continue as if there was no problem, and I might find my machine 'printing in mid air" after the z dropped. It would act like it did not know any different.

In my case though, the printing stops as soon as the z disables. The system knows something is amiss...

 

Share this post


Link to post
Share on other sites

In my case though, the printing stops as soon as the z disables. The system knows something is amiss...

 

Oh! That's completely different then. None of the 15 beta testers have experienced this problem then. It probably has nothing to do with the Z axis. For some reason it stops the print early. Maybe you have the "pauseAtZ" plugin enabled? It may be enabled from some print you did long ago. Check the plugins tab in cura.

 

Share this post


Link to post
Share on other sites

Oh! That's completely different then. None of the 15 beta testers have experienced this problem then. It probably has nothing to do with the Z axis. For some reason it stops the print early. Maybe you have the "pauseAtZ" plugin enabled? It may be enabled from some print you did long ago. Check the plugins tab in cura.

 

I believe it has everything to do with the z axis shutting off. This is the only reason the print stops.

 

Share this post


Link to post
Share on other sites

OK, so I got some time tonight to try some things. I did try to install Cura 14.07.1 and then try to upgrade the firmware again through this installation. Still have the same problem. I also tried to reinstall the firmware as an original Ultimaker with no heated bed kit, and it still did not clear up the problem. Where I stand now is the firmware is installed as it should be with the heated bed kit option selected.

After some more testing I found out that all four of the motors turn off exactly 1 minute after COMPLETING its last command. That is to say, if the y axis motor completes a command it will turn off 1 minute after that completion if no other y axis command is given. All the other axis may still be active if they have not exceeded their own 1 minute timeout, but they will turn off eventually if they achieve a 1 minute pause between completion of the last given command and receiving a new command. This was tested by opening a Pronterface print window and issuing HOME commands to individual axis and timing the event.

Because all axis are doing this on what has to be a set 1 minute timed interval, it seems that the #define_DISABLE settings must be set? Or some other firmware setting enabled that would affect the axis standby status?

As it stands I cannot use the printer for any large prints. The z axis timeout will come into play while the machine is working on large infill areas, and when that timeout hits the machine stops the print immediately.

Daid, is there a way I can query the #define_DISABLE settings in the firmware? Or just set it and save?

 

Share this post


Link to post
Share on other sites

So I may have found a work around, but it raises another question. It looks like if I issue a M84 S0 command on print startup, the inactivity timeouts are turned off. Going to have to test it for real on an actual print. But this means that the firmware starts up with the timeouts set to 1 minute on all axis. Does this give you guys any EUREKA! moments to know where my problem resides? If the M84 S0 command fixes things by being placed it the startup gcode then we could consider problem solved. But I do like to find the ghost in the machine when I can... I mean, never had to do that before...

 

Share this post


Link to post
Share on other sites

I believe it has everything to do with the z axis shutting off. This is the only reason the print stops.

 

When the stepper is off the machine doesn't know if the Z axis is moving or not. So why has this never happened to me and the other 15 beta testers? I find it hard to believe I haven't printed a bottom layer that was > 1 minute. I guess it's possible. One print in particular I'm thinking of that I did a few months ago should have been about 5 minutes to print the bottom layer.

Maybe I have an older version of the firmware.

 

Share this post


Link to post
Share on other sites

On the ulticontroller go to "control" "firmware". I have:

Firmware version 13.12 (May 6)

I just realized I did a ninjaflex print 2 days ago at 10mm/sec (slow!). The bottom layer was solid. It was about 1.4 seconds per infill line. There are about 180 infill lines. (it was shaped long and skinny like a thick pencil but square) That's over 4 minutes and it doesn't count the shell or the brim.

I've definitely printed over a minute on one layer with no problems.

 

Share this post


Link to post
Share on other sites

OK, so I may have caused a lot of head scratching for nothing. Something happened during a lot of test printing last night. and I found I had made an assumption that led me off on the wrong path. Here's how that path started;

After installing the heated bed upgrade, I noticed that the z axis would drop on me while running the bed leveling wizard. If I took too long turning the leveling screws, the z would turn off and then I would have to start over. That stayed in my mind as something I had not seen before....hmmmm

After upgrading, next step of course was to find something to print out of that flexible filament I had not been able to use until now. I found a cell phone case file that looked interesting and started it up. I came back a few minutes later and the print had stopped and my bed was all the way down. hmmmm...that z axis, what's happening here? I tried the print a few more times and watched it for a while till I thought things were good, but would always come back at some point to a stopped print and the bed all the way down. The print didn't always stop at the same point either, but the one thing that was common was the bed dropped all the way down every time.

So then I played around with the z axis many times in the pronterface window and started noticing that after jogging the z I could expect it to turn off after 1 minute and drop all the way down. I had not seen this before the upgrade either. Everything was starting to point to something wrong with a z timeout or similar.

Last night I realized that I had always been using the same print file to test the new upgrade, a file I had never printed before. I ASSUMED it was printable! No weird overhangs, shelves, or anything unusual. In fact every time it failed it was printing bottom layer infill?? It is a rare occasion that Cura has had a problem with files I have tried, but this time it seems that it doesn't like this one. I ran a test where I forced an M84 S0 command in the startup gcode to disable the stepper motor timeout and started the same print up again. Watched it for a while and after about 5 minutes into the first layer it just stopped, like every time before. BUT,this time it was obviously not due to the z-axis disabling, the M84 command held the z on and it indeed never turned off. ......oohhh,ok, insert foot here,,,,try another model to print?

So far I have printed a few items without issue and am going to test a larger item tonight.

So it looks like I was possibly having a problem with CURA not wanting to digest that cell phone case and I was attributing the resulting print failures to conditions that were new to me with the heated bed upgrade, namely a z axis that moves when there is no holding power to the motor.

I do have a last question then, Is it normal for the z motor to disable during the bed leveling wizard after 1 minute? It just seems odd that this would be the case. It gives me very little time time to make adjustments before I lose my z height positioning. Prior to this upgrade, have I always been relying on my z axis to be tight enough to hold itself in place during this setup without the stepper keeping holding power?

 

Share this post


Link to post
Share on other sites

I am relieved to read I am not alone!

I have installed the new heated bed upgrade on my dual extrusion Ultimaker original.

Bed leveling I had the same thing, z axis dropped in about 10mm steps, I think after 25 seconds. Eventually I worked around that.

But on printing I have the same thing: after about 30 seconds the the bed drops about 10mm and then it either drops further by the same amount or stps - but in any case the z axis/ z motor starts to give a ticking noise.

When I touch the spindle I can feel attempted or true movement forth and back. It is so small it is not visible but clearly detectable by hand and ear.

I tried to support the bed by hand while printing but that has no influence.

I have written to Ultimaker support but so far no answer.

Are you all having a good advice for me?

My case is same but different, the printer continues to "print" in mid air after the bed dropped.

Thanks for any comments.

ga

Share this post


Link to post
Share on other sites

I may be the one to blame: I ripped the wire of the board cooling fan while converting the printer.

So presently the board has no forced cooling. Initially I did not think of this but from other discussions it became clear that the controller overheats. So I think and hope I can solve this by replacing my fan.

Otherwise the HBK kit is a model in completeness and well thought out.

 

Share this post


Link to post
Share on other sites

Daid knows about the problem where the bed slips down during leveling. I think he may have fixed this on a newer version of Cura but you would have to upgrade your firmware. But once your bed is leveled once you should be good for months. I haven't leveled my bed since the first time I installed the kit.

The printer runs perfectly fine sideways or even upside down so you could run the printer on it's side with a fan blowing on the electronics or you could level the bed this way also.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy