Jump to content
Ultimaker Community of 3D Printing Experts

CuraEngine size is half


Recommended Posts

Posted · CuraEngine size is half

Hello Daid,

When I am using package.sh to build Cura.exe, the size of CuraEngine.exe is approximately half compared to CuraEngine.exe packaged with the release version from software.Ultimaker.com. Gcode toolpaths within my CuraEngine do not work on any machine other than the build machine

I have shared a link of package.sh

https://www.dropbox.com/s/9e1pgmbzrpsv889/package.sh?dl=0

And I have commented only the following lines

#package the result

if (( ${ARCHIVE_FOR_DISTRIBUTION} )); then

if [ $BUILD_TARGET = "win32" ]; then

#rm ${TARGET_DIR}.zip

#cd ${TARGET_DIR}

#7z a ../${TARGET_DIR}.zip *

#cd ..

#if [ -f '/cygdrive/c/Program\ Files\ \(x86\)/NSIS/makensis.exe' ]; then

rm -rf scripts/win32/dist

mv `pwd`/${TARGET_DIR} scripts/win32/dist

'makensis.exe' -DVERSION=${BUILD_NAME} 'scripts/win32/installer.nsi' >> log.txt

mv scripts/win32/Cura_${BUILD_NAME}.exe ./

# fi

else

echo "Archiving to ${TARGET_DIR}.tar.gz"

$TAR cfp - ${TARGET_DIR} | gzip --best -c > ${TARGET_DIR}.tar.gz

fi

else

echo "Installed into ${TARGET_DIR}"

fi

 

  • Link to post
    Share on other sites
    Posted · CuraEngine size is half

    Daid,

    thanks for your reply. I have installed Codeblocks and still getting the following error. Also I am using a windoww 7 operating system

    C:\Github\CuraEngine>mingw32-make all

    The syntax of the command is incorrect.

    mingw32-make: [build/] Error 1 (ignored)

    The syntax of the command is incorrect.

    mingw32-make: [build/modelFile/] Error 1 (ignored)

    The syntax of the command is incorrect.

    mingw32-make: [build/utils/] Error 1 (ignored)

    g++ -c -Wall -Wextra -Wold-style-cast -Woverloaded-virtual -std=c++11 -DVERSION=

    \"DEV\" -isystem libs -O3 -fomit-frame-pointer -march=pentium4 -flto src/bridge.

    cpp -o build/bridge.o

    Assembler messages:

    Fatal error: can't create build/bridge.o: No such file or directory

    mingw32-make: *** [build/bridge.o] Error 1

     

  • Link to post
    Share on other sites
    • 2 weeks later...

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...