Jump to content
Ultimaker Community of 3D Printing Experts

CURA (14.09) looses config after a crash


Recommended Posts

Posted · CURA (14.09) looses config after a crash

I do find this really odd. As Cura never deletes the configuration file.

On one of these crashes, can someone try to see if they have a log file, it should be in the installation directory of Cura, called "output.txt"

 

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    I do find this really odd. As Cura never deletes the configuration file.

    On one of these crashes, can someone try to see if they have a log file, it should be in the installation directory of Cura, called "output.txt"

    I am sure I can trigger a crash.. Had 5 this week already, so I am sure I can trigger one.. If I do, I will get the log file.

    I am not sure that the crash "deletes" the config.. But it clearly triggers CURA to start all over again and loose everything that it has..

    Jon

     

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    I have had several crashes over the weekend and have the Output.txt files (And also backups of the config after the crash) which I will upload loater...

    Once I restarted CURA, I would see the wizzard.. I would then quit the app.. Copy my "config" files back and re-run Cura.. And now the wizzard does not appear.

    However, the "preferences" are not restored, so I still need to change to PronterfaceUI and set my Filament price.

    But alteast I can copy my config back.. But its still annoying as I loose the settings that I was running on my last job..

    Let me know what files you need and I will get them uploaded later.. Can I attach a file to this forum? Or do I just copy/paste it as text?

    Jon

     

  • Link to post
    Share on other sites
    • 2 weeks later...
    Posted · CURA (14.09) looses config after a crash

    Still suffering with this.. Can I give you anything to help debug this?

    That said, I notice that in the RC loads, its starts up with a config, which I guess imports from an older version.. So I wonder if the behavior has changed?

     

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    That said, I notice that in the RC loads, its starts up with a config, which I guess imports from an older version.. So I wonder if the behavior has changed?

     

    Latest RC (14.10-RC6) has changes in it to look in more locations for older config files to copy, if no config is found.

     

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    Latest RC (14.10-RC6) has changes in it to look in more locations for older config files to copy, if no config is found.

     

    But isnt there a danger with that approach that CURA might open an old config from somewhere else? Atleast now you KNOW that its crashed.. And you are forced to set it up again.. I fear that if CURA goes looking for other configs, its could find something old and out of date.

    Jon

     

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    That feature is more for copying settings on a fresh install from older installs.

    Losing settings is just something I rather do not have happening in general ;-)

     

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    That feature is more for copying settings on a fresh install from older installs.

    Losing settings is just something I rather do not have happening in general :wink:

     

    Understood.. I am still using 14.09, and have only looked at RC5,6 (and now 7).. I think I might shift over to the RC loads and will see how it goes after a crash.

     

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    Major resurrection, but I figured it would be more appropriate than rehashing the same information.

    This is still an issue with Cura 15.04.2.

    If Cura doesn't shut down correctly, you will get the Fresh Install menu. Machine settings, preferences, basic settings and gcode are lost and have to be redone every time.

    If you need any kind of data or testing let me know. I love Cura, but having to set it up everytime is driving me away.

  • Link to post
    Share on other sites
    Posted · CURA (14.09) looses config after a crash

    Hi,

    I'm using Cura 2.1.3, and it seems to have the same behavior.

    The result of a PC freeze is that my stored printing profiles were gone

    In notepad these files all show up empty. But the logging nicely dumps the files contains 243 NULL bytes.

    Question: I supose the workaround is to back up all files (and subfolders) in

    C:\Users\\AppData\Local\cura

    is the correct data set to be restored, excluding the *.log files?

    The log file reports it can't load the profiles.

    An extract from the log file:

    2016-10-03 20:10:06,213 - INFO - Command line arguments: {'disable-textures': False, 'external-backend': False, 'file': [], 'debug-mode': False}

    2016-10-03 20:10:06,371 - WARNING - No active machine found when trying to save setting visibility

    2016-10-03 20:10:06,373 - DEBUG - Attempting to kill the engine process

    2016-10-03 20:10:06,376 - ERROR - An exception occurred loading Profile C:\Users\mark/AppData/Local/cura\profiles\Fast+Print+%28Customised%29+%232.cfg: File contains no section headers.

    file: '<???>', line: 1

    '\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00'

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...