Jump to content
Ultimaker Community of 3D Printing Experts

UM2 stopped x/y mid print


Recommended Posts

Posted · UM2 stopped x/y mid print

This is a bit of a weird one, but I started a print earlier, and after about 20 mins I came back to hear no real noises (other than the fan), when I looked in to the build area, I saw that X/Y had just stopped, and the head was sat in the same place, extruding away merrily..

The display was indicating it was mid-print with the progress and time remaining still showing, and I could abort the print, at which point the bed/head all moved back as normal after aborting.

Here's the pics..

DSC08623 Small

DSC08622 Small

After aborting, I tried to restart the print (after removing the old item off the bed) and it moved the head to the correct place, moved the bed up, but nothing extruded and again X/Y wasn't working, it just stayed at the front left of the build area.

So I power cycled the printer quickly, and I assumed the nozzle may have blocked due to sitting around extruding into itself, and did a full material cycle, atomic clean and reloaded the material.

At this point I happened to glance on my shelf and noticed the big blob of plastic that I found around the entire nozzle (under the guard) that I had to remove the day I bought the printer home (I bought it second hand and didn't spot it when checking it over), it was lodged above the nozzle guard enveloping the nozzle.

DSC08624 Small

Just to be safe, I factory reset (It's already got the latest firmware when I first launched CURA the other day), and then re-levelled the bed, and restarted the print which is so far doing OK.

My question is really what could have caused the issue? I'm now a little nervous because I am starting to suspect the previous owner may have run into the same issue judging by the amount of green PLA melted around the entire nozzle block (now removed and cleaned), which I fear may have happened to me had I not spotted it within a few minutes.

Just to re-cap, the symptoms where just no x/y movement at all but seemingly everything else working as expected, and it would home/move fine when I aborted.

I will obviously leave it printing, and see what happens, but I just wonder if anyone has any advice or may have heard of this before?


  • Link to post
    Share on other sites

    Posted · UM2 stopped x/y mid print

    This sounds like a SDcard issue. Did you eject the SDcard properly before removing it from the slot in your computer?


    Being honest, no I didn't (My card reader does have an activity led that I always wait to show no activity for a few seconds before removing), but I never removed the sd card at all between it stopping and eventually restarting the print, and its happily completed that same print after resetting the um2.

    I've since removed the card to add the next file to it and have used the 'safely removed the device; in windows just in case though..

    I presume the issue of not ejecting would be an incomplete file/corrupt file system in some way?


  • Link to post
    Share on other sites

    Posted · UM2 stopped x/y mid print

    It happens sometimes yes. The gcode is not fully written so the print just stops.


    Thanks, I'll bear that in mind!

    I think in this particular case, the file was intact since I later printed it OK from the same SD card that had not left the UM2, I'll keep an eye on it, I've set up an IP Camera so I can monitor it during the day, I only work 1.5 miles away and can pop home any time should I spot it stopping again!


  • Link to post
    Share on other sites

    Posted · UM2 stopped x/y mid print

    Just an update, It printed OK for a few days, no stops/pauses, but today it's started playing up again!

    I was trying to do a test print of Emmet's Gear Bearing to tweak settings for good dimensional work, and after a few aborted attempts due to incorrect settings, I started a print which just stopped after 20 minutes.

    The machine is sat there, it thinks it's printing, showing the time left and I can go through the usual tune menu's etc. I could abort the print, at which point the bed and X/Y home, so clearly it can move the head!.. If attempted the print immediately after this, the bed warms, the head heats up, it does the pre-extrude and then stops, no X/Y.. I aborted and tried again, same thing.

    I had to power cycle the machine, then it started printing, but after 1 hour it has stopped mid-print again.

    I'm going to try another SD Card and see how it goes, but I'm wondering if there is anything I should look at?


  • Link to post
    Share on other sites

    Posted · UM2 stopped x/y mid print

    I'm using this thread to document the issue, so will keep posting anything I find.

    One oddity I just had was it stopped again, but exactly when my PC came out of sleep! It could be USB related, either the PC suddenly powering the port or some other interaction, I forgot I actually had it hooked up via USB and will be relieved if that's all it turns out to be!

    I'll keep printing with no USB connected and see how it goes over the next few prints!

    Just to be clear, it's not resetting the board due to the serial port opening (I've since done that, using KiTTY to talk to the UM2), it was potentially causing the X/Y to just stop mid-print, even though when you abort the print, it can move the head 'home'..


  • Link to post
    Share on other sites

    Posted · UM2 stopped x/y mid print

    Hopefully final update!

    Removing the USB cable from the UM2 has seemingly completely solved the problem!

    I've been printing (touchwood) for nearly 2 weeks and not a single hiccup!!!

    I thought it best to update the thread, since if anyone else gets this issue, they will at least known one possible cause!


  • Link to post
    Share on other sites

    Posted · UM2 stopped x/y mid print

    Yes, I think this is a known behavior if the printer is connected via USB to a computer - you can get these freeze ups when the computer wakes or sleeps. The short answer is simply 'don't do it'.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    • Create New...