Jump to content
macua85

Heated bed kit won't stop at 70, keeps heating during print

Recommended Posts

Posted · Heated bed kit won't stop at 70, keeps heating during print

Hey guys,

The heated bed has been working perfectly earlier, now it won't stop heating at the set temperature, it just keeps going. Any ideas as to what is wrong? Its brand new by the way.

More info, the bed is heating even when I haven't hit print. Something has gone seriously wrong. I haven't changed anything. I have to unplug heated bed to get it to stop.

Ok last bit of info, with printer turned off...plug power to HBK in, and the bed starts heating up immediately.

Reinstalled firmware, no different still does the same thing.

I'm puzzled and disappointed, and not sure what to do!

Thanks,

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Read on another forum something about ramps board(?). Could that fail so quickly, within one day of printing (if that is the cause)?

More I read, the worse it sounds....control board failure. This is pretty shitty, for it to last 1 day! I'm so unlucky.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

I moved this thread as you asked. It also shows up in the old spot but when you click it, then it jumps to here.

Does the bed heat up even when "goal temperature" is 0C?

Does your heated bed use a relay? Or a FET? Do you use the mosfet on the ramps board to control the heater directly?

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

sounds like the same failure that mine had. others have reported that happened if they've used the switch to turn off the printer while the bed was on. use case: in the middle of the print and something goes wrong, turn the printer off using the switch, pcb fails. mine failed after five minutes after starting the print, print just stopped and the bed started going up in temperature. I'd used it for a few weeks before then with no problem.

still no official explanation, nor a notice about not shutting off the machine with the power switch, if that is one of the causes.

the bad news is it might take a while for a replacement, the hbk is out of stock. I've asked in another thread if catching up with sending out orders for full kits will have priority over replacements, but i still haven't had a reply.

sorry that your start has had some bumps, i know it can be disappointing.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Thanks for the replies guys, especially flux, I've sent a ticket to ultimaker. I just hope the defective warranty issues get priority over new orders.

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Are you talking about the official HBK? Can someone please explain what's exactly going wrong in the mentioned use case and comment on possible counter measures to avoid a dammage?

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

yes, the official hbk. i don't think the use case is clear at this point, and until now there's been no real answer from ultimaker as I don't think they've decided if it's faulty install, a failing component, or design issue. some have said that the fail happens if they shut off the ultimaker during print while using the hbk, mine just failed 5 minutes into the print. it stopped printing and the bed started runaway heating. not sure what would have happened if i hadn't been there to notice and turn it off.

i would say for now, do two things, make sure the connection of the 2 main leads have a good contact at the push on connector, and do not shut off the printer while the hbk is still heating. use whatever ui you'are using to control the print to shut off the hbk before stopping. But, and a big but, I'm not sure if just setting the temp to zero actually solves the problem. voltage should be off, but ...

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Thanks fluxline for the details. Then maybe it's not a bad idea to plug both printer and heatbed into a switchable power strip and use its switch as panic switch for the time being?

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

that's for um to say, but i don't think that solves it.

i asked http://umforum.ultimaker.com/index.php?/topic/8516-heated-bed-kit-lead-time/?p=80877 for a statement from ultimaker regarding the problem, but was a told few posts later that it wasn't needed. I know the engineers are looking at the idea that some have installed the hbk with the power supply still plugged. i know for sure that was not my case, i'm also sure that the connector was secure because while the picture in the instructions was correct showing the same push type connector, the instructions said turn the screws tight and i spent some time making sure the connection was secure.

in short, not sure what the problem is or what the fix/prevention is. hopefully we hear something soon and i would say at this point, do not print unattended with the official hbk.

edit: one thing though, do you still have the old power supply still plugged in somehow? the hbk comes with a power supply that supplies power also to the arduino with a short patch cord.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

edit: one thing though, do you still have the old power supply still plugged in somehow? the hbk comes with a power supply that supplies power also to the arduino with a short patch cord.

 

I don't have the HBK installed yet (I'll install it on someone else's machine; not on mine; and it has to work properly there...). But thank you for pointing out. It's certainly better to have only one power supply.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

seems you and i are in a similar situation. we were looking to install about 10 for a project, decided to use my own for a test and now it is disabled.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

the bed started runaway heating. not sure what would have happened if i hadn't been there to notice and turn it off.

 

Not a complete disaster. Normally (if you don't insulate or cover the sides) the bed only gets to about 110C to 120C maximum I'm told.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

I can imagine it is easy to destroy the FET inside the HBK with static electricity simply by touching the heated bed after walking across a rug in a very dry house.

But I can't imagine how the FET could break (or the arduino controlling signal) just because you cut power. I'd have to see the schematic.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

I don't use the patch lead as I have dual extruders (use the oem power supply for um and the hbk one solely for the bed. I hadn't even commissioned the printer when I installed the hbk, I built the printer with the hbk so definitely not a case of installing with the power on. Installation is also very straight forward. Pretty impossible to get it wrong. Mine also failed randomly on a print. So glad I happened to be sat at computer watching the temps!

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

I have build a bed myself and I have turned the machine off at mid print number of times. The difference is my bed is controlled with a separate switch (like a solid state relay). It is also powered with 24V and I have a DC DC converter to 19V like the UM heated bed kit does (I presume that it does that). In my case none of the 24V can leak into the UM board. Don't know the schematics of the heated bed kit.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

The circuit which switches the bed on and off is the same as on the Ultimainboard. The FET can fail if it is shorted. Unfortunately the failure mode of a FET is it stays always on. Turning the printer off while the bed is on should not cause any problems.

It is important to keep in mind to always disconnect the power before performing any maintenance on the machine. When the printer is turned off there is still power on some parts of the machine. The 24V to 19V circuit stays on and there is still 24volts on the bed, it is just not pulled to GND.

I will look into this and will let you know more soon. You can contact support for a new board.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Thanks Cohen for the information. Your remark about the FET being the same as on the Ultimainboard together with the previously mentioned (by gr5) electrostatics rises the question if I risk the FET when I wipe the glass plate clean before each print on my UM2 with a microfiber cloth.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Thank you far taking a look Cohen. One data point, as I wrote before and discussed with support, all work I did with machine was unplugged, ran for several weeks, and then failed during a print.

just shot gunning the issue now and the wall is becoming a mess!

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

rises the question if I risk the FET when I wipe the glass plate clean before each print on my UM2 with a microfiber cloth.

 

Interesting. Maybe. I don't think so - you need some kind of conductor to jump the spark to the plate suddenly. You can build up a huge charge on the glass but unless the top surface is conductive - like metal conductive - or salt water then I think not. Because the top surface of the glass isn't conductive a spark at the edge would only transfer the charge at the local area and not relieve the charge on the rest of the surface. So it would be very little power.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Hi Cohen,

Thanks for the reply. I've opened a ticked for the issue and new board but not heard anything back yet. Id be happy to return my board for analysis when I have a replacement if you guys would find it helpful?

Thanks,

Anthony

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

For those interested the Altium design files and the schematic can now be found here:

https://github.com/Ultimaker/HeatedBedUpgradekit

 

Hi Cohen,

Thanks for the reply. I've opened a ticked for the issue and new board but not heard anything back yet. Id be happy to return my board for analysis when I have a replacement if you guys would find it helpful?

Thanks,

Anthony

 

Hey Anthony,

it would be great if you can send the board back. If you can let support know when they contact you that would be great. Thanks!

Coen.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Support is crazy busy. It may take a few weeks. But if you call them during normal working hours in The Netherlands you can usually get instant service.

 

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

Support are already on the case. I have high hopes for 2015!

Share this post


Link to post
Share on other sites
Posted · Heated bed kit won't stop at 70, keeps heating during print

I got the same issue with the extruder on my Ultimaker2 Extended. It won't stop heating.

What is the solution?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 19 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!