Jump to content
Sign in to follow this  
dipicorg

Pause at Height incorrect...

Recommended Posts

Posted · Pause at Height incorrect...

The Plug-In may have a Problem. I used an Item to print with Layerheight of 0.2mm and wanted to insert a Nut at 13.6mm (Layer 68) but there is no Pause at this Height. It only does this Pause at 13.5mm instead.

I beleive that it would be helpful to have also displayes at which Layer the Pause should happen (Layer 68 => 13.6mm). This is helpful because in Cura you can select every Layer wit Shift-Up/Down and see where the Pause is useful.

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

Just to make sure. Is the initial layer thickness set to 0.2 also. Is the Cut off object bottom set to zero?

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

Hi

All Layers are set to the same (0.2mm). It seems that the Plug-In does only make a Pause when the Value is a litlte over the choosen Layer. There is no Offset or so for the first Layer and therefore it should mak the Pause at the selected Layer (68 in my Case).

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

I have seen that it needs some Time to update the Layer View. Changes are not displayed direct after I make it. It works with 0.1mm Layer Height and is easyer to set this Way. (13.6mm = Layer 136)

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

I can't get it working... The Item is the following:

http://www.dipic.org/PFS_1.stl

Layer Height: 0.1mm

Cut Off Object Bottom: 0.0mm

M3 Nut insert: (Pause required at): 15.5mm

The Plug-In does not make a Pause at the required Height and I don't know why.

What am I doing wrong with this Part/Plug-In? (latest Cura used)

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

Hi dipicorg,

I was able to reproduce the issue when playing around with the print settings a few times. I was also able to get it to work properly on the first few updates.

Try settings all the print settings and plugin settings you need for your print, let it slide, restart Cura, load your object again.

I'll dig a little more to see why after a while it stop working.

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

Ok so even if the display doesn't show it. The pause still get written in the gcode.

 


;LAYER:77
;TYPE:CUSTOM
M83
G1 E-5.000000 F6000
G1 X190.000000 Y190.000000 F9000
M84 E0
M0
G1 E5.000000 F6000
G1 E-5.000000 F6000
G1 X119.217000 Y110.010000 F9000
G1 E5.000000 F6000
G1 F9000
M82

For your info:

- The pause will occur at the first height >= to the given number so the layer height should not impact the plugin.

- The pause occur BEFORE printing the layer.

- The plugin doesn't support "Print one at a time" mode.

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

The plugin doesn't support "Print one at a time" mode

this might be the Problem, even if I only print one Part....

 

Share this post


Link to post
Share on other sites
Posted · Pause at Height incorrect...

No that's fine. It just wont get in the code again after it hit the good height a first time.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!