Jump to content
Ultimaker Community of 3D Printing Experts

UM2 Heater Error


Recommended Posts

Posted · UM2 Heater Error

Ok, sorry for hijacking the thread. It is not the firmware. Went back to 14.12.1 and the heater error appears again.

I did change the nozzle, teflon piece and the fan shroud.

@Daid: What exactly is the meaning of the heater error? What triggers it? Do you check for a big temperature difference? I am asking because I see that right before the error is triggered, the temperature fluctuates quite a lot due to the cooling fans. It went as low as 204° (from 210°).

 

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    @Daid: What exactly is the meaning of the heater error?

     

    hi nicolinux

    i have the same problem since 14.12

    fan 100 % on the first layer ------> heater error

    fan 50 % on the first layer ------> heater error

    fan 20 % on the first layer -----> OK

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    Hey Nico:-)

    Maybe moving your questions to more appropriate places.

    Stupid mishaps suitable for Christmas, which was really a great time for may not be sufficiently tested Cura updates? Self-blame, if one would like to have during the festive season, to date his System.

     

    Because there are still a few more matching messages:

    http://umforum.ultimaker.com/index.php?/topic/8927-um2-error-temp-sensor/

    http://umforum.ultimaker.com/index.php?/topic/8785-error-stopped-heater-error/

    http://umforum.ultimaker.com/index.php?/topic/8768-cura-v14121-currently-perhaps-a-few-screws-loose/

    Maybe there are not incorrectly installed heater and temp sensors. Perhaps the fault detection in the firmware is too sensitive. Maybe ...

    New Year Greetings

    Markus

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    Just like me:

    No problems with firmware / Cura before v14.12.

    But checking the heater, there is only after v14.09, I think.

    Markus

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

     

    @Rigs that could be the case if you have a different fan base but if you have the OEM it would be pretty surprising. Could be a screw up in the PID.

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

     

    For me, it returns the error message only if you play around with Move material not when printing. No changes to the fans, but thermal compound with silver content used sparingly for heater and sensor (... after the occurrence of these ERROR - HEATER message, not before, I think).

    SilverGrease

    Markus

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    With the 14.09 or 14.07 no problem.

     

    Yes.

    Firmware 14.12 adds this "heater error". It's added to prevent anything bad happening to your hotend.

    Firmware 14.12.1 updates on this, by changing the parameters for this error to happen. So that it does not happen on machines with weak heaters.

    How does the heater error work?

    When the heating is on full power (100% output) a timer starts. This timer is stopped as soon as the heating is no longer 100%. The timer runs out after 20 seconds. After these 20 seconds of full power heating, the temperature is compared to the temperature at the start of the timer. If the temperature did not increase by 10C then the heater error is generated.

    Now, the worst case I've found in the office. Was a 21W heater (normal is 25W). Which warmed up 20C in 20 seconds, starting from 260C dropping to 200C and then at 200C turning the heater full on. Pretty much the worse case that can happen, as you first get a continued drop from the cooling down.

    Now, if you are getting this error. Check the following:

    * The heater and temperature sensor should be fully in the hotend so that no full round metal is sticking out. As that's bad stuff, and that's exactly what this new error is trying to detect.

    * Make sure you have firmware 14.12.1 or newer. As 14.12 was calibrated on machines with strong heaters by mistake.

    * The fan air-flow should not hit the hotend blok. Some custom fan shrouds have the bottom open. Which isn't that great for airflow when the bed is near. (Cura's "fan full at height" setting can help here to battle this)

    (Bold so I can find this post quicker and referrer back to it easier)

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    Hey,

    After, updating my firmware from 14.09 to 14.12.1 I got the same error.

    But as I use the original fan and everything works fine I recognized, that the error is only displayed if the nozzle is already hot.

    When I start a new print directly after abort the previous one, the nozzle is hot enough to print again directly, so the target temperature is not 10°C higher than the one on which the countdown started and the error is displayed.

    If I let cool down the nozzle before starting the print again, everything works fine.

    I think you can add a check if the current target temperature is reached or above it.

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    Hi, i had the same problem with the "Heat Error" with Cura 14.12.1. on my UM2. So i had a look at my hot end and the temp. sensor and everthing looks fine. But i don't give up and found the solution. Problem was the fan duct - i used the one by venkel V6, which did a good Job so far. But as a switched back to the original one, the Error was gone :-P

    So check you fan duct - if you don't use the original one. This may cause the issue.

    bests,

    Conny

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    The heater sticks out of the block on my UM2 by several millimeters. It just won't go in any further but the temp sensor is all the way in. Both seem to want to slide right out as well when the machine runs - there is no real friction holding them in. Any suggestions on how to get them to stay in the block - some kind of adhesive maybe ? Is it standard for the heater to stick out of the block a little bit ? I have a new hot end that i just received and if I test fit the heater into this block it still doesn't go in completely. There is metal sticking out and the heater does not appear to be warped or swollen in any way. Suggestions ?

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    The heater sticks out of the block on my UM2 by several millimeters. It just won't go in any further but the temp sensor is all the way in. Both seem to want to slide right out as well when the machine runs - there is no real friction holding them in. Any suggestions on how to get them to stay in the block - some kind of adhesive maybe ? Is it standard for the heater to stick out of the block a little bit ? I have a new hot end that i just received and if I test fit the heater into this block it still doesn't go in completely. There is metal sticking out and the heater does not appear to be warped or swollen in any way. Suggestions ?

     

    First, you could take a look into the assembly manual (from page 49).

    You can take the photos and the instructions as a reference.

    Or perhaps post your own photos here for comparison...?

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    First, you could take a look into the assembly manual (from page 49).

    You can take the photos and the instructions as a reference.

    Or perhaps post your own photos here for comparison...?

     

    Mine is obviously out of spec based on the photos in the assembly manual. Thanks. I will have to replace this hot end with the new one that fits correctly.

     

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    OK this is getting beyond ridiculous. My Ultimaker 2 had some problems in the past but this one is out of order. Why place a flag in a system when every ultimaker is different. The hotend and block are not a very good design but thats not the main complaint. You installed different heaters in every ultimaker. You have a 21W, 25W, and maybe even a 30W kicking around somewhere. And what really got me mad about the situation is that an OFFICIAL shroud is not "compatable" with the new firmware? What? So you made a product that has no scalability. Once a new firmware is released, I would have to reprint or order new parts. And considering now I get this error, there is no way for me to print another shroud. I have a new Olson Block and its a really nice kit but at the end of the day, it was the printer and the firmware that screwed the whole thing up. This is NOT a finished product and should not be viewed as such. This new feature MUST be optional, not should, MUST. Put a flag in the settings menu to turn that code on and off. Since the Olson is bigger, I will be installing the new 35W heater and that will solve a problem with underheating that I recently had. But that wont solve the problem of it turning of. Currently, even if I wanted to, I am not able to print spare parts and forced to revert back to the 14.07 firmware. That firmware had another problem, before I updated. Prints well for 3-4 layers, then skips like 5 or 6 and continues like nothing happened. I fixed the STL and renamed it and deleted it off the SD but still, breaks layers in the same place. So, I have a feeling that once I revert, same problem may arise. Could you, maybe, make a patch for the Firmware that has this monitor function as a toggle? Dont release something into the wild if it hasnt been tested by masses. Or at least have experimental functions under toggles so that anyone who is not sure if it works for him, could simply turn it on or off if something was to happen. Also, WHY make it a critical failure error. That just adds to the problem more than it solves. I cant get into the menu, if it aborts half way through the print, which means I cant control the temperature and keep the hotend hot so it wont stick into the table. I cant cancel print if the error pops up, the heater shuts down, then what? The material is still fed like normal but the temperature is dropping in the hotend. That will cause more of a failure than the hot end not being able to control the heating evenly. Feeder breaks and maybe even a burnout of the stepper. Locking me out and asking to contact support is the dumbest thing to do on a hot and working machine. I had to throw the physical switch at the back quickly in order for me to get my control back. Get this patch as quickly as possible as this is an EXPERIMENTAL function and not the final. All the machines are made different so unification will require more work.

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    Any updates on this thread & the error issue? I agree there should be a setting to toggle that warning on/off - especially for those of us with a UM2 that is now out off warranty. If it fries the heater - "Oh well" - I'll have to replace it anyway.

    I just swapped out the original nozzle for the Olsen one & I've run into the error using a .8 nozzle. So far so good with .4 nozzle. I read that UM2s are supposed to be shipping with the Olsen block, so from a support standpoint, it would be good to increase the timer value, or at the very least make it adjustable/dynamic.

  • Link to post
    Share on other sites
    Posted · UM2 Heater Error

    Any updates on this thread & the error issue? ...

    Ultimaker use a 35W-Heater, so you don't have the problem with this error.

    I am testing my own design of a heater-block and have the same problems.

    The olsson-block have more masses and that's why the time for heating it up is too long in some cases. More material (0.8) amplifies the problem.

    I think the user eaglevision is right. This feature must be optional.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...