Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
edit-mesh

differing shell thickness

Recommended Posts

hello

i'm trying to print a solid "U" which has a thickness of 2mm.

in cura 14.11RC7 i set shell thickness to 0.8, 100% infill and i get different wallthickness in my print.

i changed the model to a thickness of 1.6mm and printed with 0.8 thickness and no infill again, same result...no matter what i am trying, the left "leg" of the "U" has a gap between the walls.

i did a new bed leveling and checked the alignment of the axis/printhead...controlled the belts also, no change

what could cause this problem?

wall thickness2015 01 13 13.36.442015 01 13 13.45.49spiralize

 

 

Share this post


Link to post
Share on other sites

to me the short belts seem to be tight , well i am not that familar with short belts though :???: ...

they don't look and feel dangeling...

curas layerview shows a perfect uniform green gap, no differences between the wallsinfill

i just tested a 1.6 mm rectangle which was uniform, deleted it loaded the "U" model, printed with same settings

and got that gap again.

i checked the given geometry, same wallthickness on both legs, no faulty mesh...

this is voodoo :-| ...

 

Share this post


Link to post
Share on other sites

Like Daid said above. Did you look in Cura if it show the same result? You dont need to print the piece to see how it will behave in a "normal" case.

In cura, change the view mode to layer view and wait for the desired layer load the tool path.

Share this post


Link to post
Share on other sites

Hi edit-mesh, do you have Repetier-host on your PC? If you do load the stl file and look at the layer view. RH sometimes shows up things that Cura may not. If you do not then mail me the stl file and I will take a look.

Also there have been a few reports of a similar problem on the forum over the past 18 months. I am trying to remember the exact cure but cannot. It is something like

set your model width to 1.61

or

set your wall width to 0.81

or

set your nozzle width to 3.9

I have seen it once or twice on my prints but it has never been important so I have not pursued it.

When you say you get different dimensions, is that because you see the gap and are assuming a different dimension or have you measured with a vernier gauge. If so what is the measurement difference?

 

Share this post


Link to post
Share on other sites

thanks for the replies guys!

@pm_dude: like i wrote already, layerview in cura looks ok :-/...

@yellowshark: i will try RH and see what it looks like- thanks for the hint !!! !!! !!! (may i send you the file as obj also?)

and does the exportformat makes a difference in cura- obj or stl ???

i am a 3ds-worker useing the obj export in 3ds max, cause i can export selected objects and don't have to delete something previously- didn't had any issues with that yet.

i also read about the 0.4 wall problem (german forum ;-) ) hmm will read it again and see if cheating with a smaller nozzle size might work, although i tried so many wall thickness parameter and it didn't show a different result.

and YES i have different dimensions :-(, not measured it, but you can see it quite well (also on my foto i think).

what makes me wonder, is that there is absolute no change with different parameters (also tried spiralized and follow surface mode- its even worser then).

 

Share this post


Link to post
Share on other sites

the short belts are the vertical ones from the motors to the pulleys, not the horizontal ones...

 

to me the short belts seem to be tight , well i am not that familar with short belts though :???: ...

they don't look and feel dangeling...

 

Share this post


Link to post
Share on other sites

Hi, edit-mesh, two prints of the model here. I sliced your model in Cura 14.07 with 0.8 walls. Looking at layer view there was a gap along the middle of the walls so it was clear that I had the 2.0mm wall model not the 1.6mm model. So I set the walls to 0.4mm and changed infill from 0% to 100%.

I also cut 40mm of the object bottom to reduce the print time. Here is the finished print, which you can see does not exhibit your problems. Note that the strings of filament are due to my mistake of not enabling retraction.

swiss1a

I then set the walls to 1.2 and infill to 0% and retraction to on and sliced in Cura 14.07. Taking the gcode into Repetier-Host I saw that

 


  • The two outside legs, running east/west had four walls with a gap inbetween.
     

  • The two inside legs running north/south had five walls with no gaps.
     

  • The central sloping wall had 6 walls with no gaps
     

I have no idea how the slicer works when you define wall thicknesses which will exceed the physical dimension in the model - all I can say is that the output was more consistent than the layer view suggested!

Here is the finished print. As you can see the walls have no gaps. Setting the walls to 1.2 though did no favours to the sloped wall!

swiss2a

 

Looking at dimensions and accuracy the results of the first run with 0.4 walls was very disappointing. Running from left to right they were

Wall1 2.42mm

Wall2 2.36mm

Wall3(the sloped wall) 2.40mm

Wall4 2.17mm

Wall5 2.25mm

 

I normally see accuracy of < .100 error and always below .150 error.

I have never printed with 0.4 walls and this was run at 50mm/s. If I am doing an accurate engineering print I never go above 30mm/s. Also I have not used this filament before and that could be having an effect.

I am going to run it again with a known filament and slower.

Also I will now have a go at running your gcode. Also I will have a go at reverse engineering it into Solidworks to check the dimensions.

 

BUT with my results so far I do not think there is anything intrinsically wrong with the model and that you do have a problem at your end. And yes I do think that changing one of the settings by 0.1 to fool the slicer might work. Another thing you could try is to rotate the model on the x/y plane by 45 degrees. That might work and it might give you some help in trying to identify the problem.

 

Share this post


Link to post
Share on other sites

Hi edit-mesh, I have just looked at your most recent post - re fooling the slicer. There was a discussion where, for example, with a 0.4 nozzle and walls set to 0.8mm, a 1.6mm physical wall was not printed properly. I do not think anyone stated why this happened but some solutions were put forward.

Searching through my notes I found a document that showed that it had happened to me, which no doubt is why I was so interested in the postings.

This pic shows the error

Swiss 3

This pic shows the result after the fix.

Swiss 4

The document is dated December 2013 and I suspect the thread on this forum was December too (or November/January). Unfortunately I can find no notes anywhere apart from the two pics.

 

Share this post


Link to post
Share on other sites

hello yellowshark

thank you so much for your testing and reporting!!!

well, the pattern of walldimensions you posted from the 1. test is almost exactly, what i get her all the time.

yesterday i sliced in cura 14.12 and rotated/mirrored the model, i also printed with a nozzle size of 0.41, all with no obvious different results- the wrong dimensions stayed at the same place of the object, no matter how i placed the object on the printerbed

so i guess this excludes a machines/belt issue at least ?!!

but reading your answer 2 times helped, because now i know, i have to open the gcode from cura in repetier-host and not the model - that definitely makes more sense :wink:.

i am sorry but not sure if i got you right in the last post: you found these pics, but not the related posting in the forum?

well i will do a search for that period...hopefully it wasn't deleted...

but right now, i still have no idea what the problem really is and no plan what i could try (what i haven't tried yet) further on

to come a little closer to a conclusion or possible workaround ...

 

Share this post


Link to post
Share on other sites

Hi edit-mesh, OK several things

 


  1. I reprinted the model at a slower speed to improve the accuracy – this time all the wall measurement widths were less than 100 micron error rate J. Although the left north/south wall was around 50microns wider than the others; no idea why, a bit strange as you seem to have the same thing.
     
     

  2. Not wanting to miss anything I reversed engineered your STL file into Solidworks; all the walls measured 2mm (accepting that the process rounds dimensions to 100 microns i.e 2.049mm would be 2.0mm).
     
     

  3. I tried using your gcode, it has walls set to 0.8mm and 0% infill. Checking it in Repetier-Host it all looked fine. The first pic shows the print with a gap running along the entire model (except for the sloped wall).
     

Swiss 5a

The second pic shows the end of the print where the top solid layers (6x0.1mm) have filled in the gap – including the left-side north/south wall you are having the problem with.

Swiss 6

There is one important point on this pic. i.e.for this 2nd print I imported your gcode into Cura 14.7 so that I could cut off the bottom 45mm or so of the model to speed up the print time. I did not change any of your settings in Cura. So it was sliced by 14.7

Conclusions:

Well I do not think there is anything wrong with your model and gcode. Maybe, as you are on a release candidate, there is an argument for trying a previous version of Cura, but I am not convinced – although I did take your gcode into 14.07 and re-sliced for the 2nd print run.

What I do not understand is, if it is a hardware problem, why is the right-side north/south wall working OK? I have to confess I am at a loss at this point.

Do youu have other rectangular models that are printing OK?

 

Share this post


Link to post
Share on other sites

haven't found something either in cura-, troubleshooting- and questions and answers- section from nov-jan 2013-2014, but fingers crossed, maybe somebody remembers that thread!

regarding my wall problem-WOW, great job, thank you for your great support!!!

to make sure i understood everything right, your last print on that model was so much better, because of using the 0.8mm wall thickness, cura 14.07 and a slower print speed ?

ok, thats what i am going to try tomorrow!

printing a normal U with 3 walls, i didn't see any wall issues.

thats why i also thought my belts are ok, but maybe i really have to tighten them also, because i noticed that even the 1st brim line, which is printed with 20mm/s by default (?)was showing a thicker wall on the left side...

could you notice something like that also? or is it not that relevant how close the brim matches the geometry because of the 1st layer z-offset?

all in all thank you very much yellowshark, i still have to try and learn a lot :-) !!!

 

Share this post


Link to post
Share on other sites

Hi edit_mesh, no the improvement in dimensional quality was due solely to reducing the print speed from 50mm/s to 20mm/s. The print was using 0.4mm walls and 100% infill. Everything I had done up to that point was using your model file and slicing it in 14.07.

This is not something I have ever paid attention to but yes the brim on the left side was quite larger than on the right side, by about 0.7mm which I find really surprising, although that part of the brim did separate slightly from the model when removing from the bed so the measurement could be misleading. I am not sure that the code is written with an intent to ensure the brim is the same width all the way around an object but with a simple geometry like yours that would be my expectation; someone from UM software would have to provide the correct answer I think.

I have no answer to it but we seem both to be having the same left and right dimensional differences with different printers and different manufacturers of printer - wierd

 

Share this post


Link to post
Share on other sites

i would like to share the data, in case anyone has time and patience to help me further on

https://www.dropbox.com/sh/bf3ikcy4fk3ici1/AAC-eFGorlHFzmRrXOzDGGCIa?dl=0

i added the cura 14.12.1 gcode which isn't printing here with the same wall thickness from the brim line on (slopewall is thicker due to construction purposes).

i would be very happy for any help or replies on my problem.

thanks in advance

imke

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!