Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
aviphysics

Initial hotend temperature set to 0

Recommended Posts

Marlin is setting the initial hot end temperature to 0. This is on a UMO with official HBK. Print was made from an SD card on an Ulticontroller. The firmware is the default from Cura 15.01-RC6.

 


M190 S65.000000
M109 T0 S192.000000
T0
;Sliced at: Mon 05-01-2015 17:01:19
;Basic settings: Layer height: 0.15 Walls: 1 Fill: 10
;Print time: #P_TIME#
;Filament used: #F_AMNT#m #F_WGHT#g
;Filament cost: #F_COST#
;M190 S65 ;Uncomment to add your own bed temperature line
;M109 S192 ;Uncomment to add your own temperature line
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G1 Z15.0 F9000 ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F9000
;Put printing message on LCD screen
M117 Printing...

Sorry for cross-posting, but didn't get any replies in the Marlin section.

 

Share this post


Link to post
Share on other sites

When I ran this code on my UMO, (code was generated in Cura) the hot end temperature was set to 0 and the machine didn't do anything until I manually set the temperature. After manually setting the temperature, the machine heated up and ran like normal.

I didn't see anything wrong with the code either, so I really don't have a clue what the problem is. It started when I last updated the firmware, so I am guessing it is a Marlin problem, though I updated Cura at the same time. I first had the problem right after updating to install a graphical controller. After noticing the problem, I flashed back to the latest stock firmware, but the problem persisted.

 

Share this post


Link to post
Share on other sites

M190 sets the bed target temperature and waits until it reaches that temp.

There are others that just set the temp but do not wait. M104 for extruder, M140 for the bed.

So you can do things like (not sure about the G4 syntax):

;start heating the bed

M140 S65.000000

; wait 60 secs to give the bed a headstart

G4 S60

; Start heating the extruder

M104 T0 S190

; wait for the bed to reach temp

M190 S65.000000

; Wait for the extruder to reach temp

M109 T0 S192.000000

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy