Jump to content

upgrading firmware version squashes mesh


Recommended Posts

Posted · upgrading firmware version squashes mesh


I ran into a weird issue today.

For a while i have been running 14.09 version of cura. but i have been running fw: 13.03 since well forever.

I use the sd card with my umo.

Today, I realized that i haven't upgraded the firmware in quite a awhile, so i decided to try the latest and went for the one that ships with cura 14.12.1.

As i was reading about some of the fixes that have been done in the last few releases of the firmware.

I re sliced my mesh and tried to run it and the mesh ends out getting printed squashed. see the image.


Um firmware issues

So i tried slicing with both 14.09 & 14.12.1 and both slices print squashed.

If i revert back to 13.03 firmware the prints exported from both 14.09 & 14.12.1 print correctly.

Can some one explain why this might occur?

I will try later this evening to go to the firmware that ships with 14.09 to see if that has the same issue.

edit: i have since reverted back to 13.03 to make sure that the issue only occurs with the firmware and it does.




  • Link to post
    Share on other sites

    Posted · upgrading firmware version squashes mesh

    Do you have a heated bed? Or did you select UMO w/HBK ? This issue is probably due to the HBK having a different steps/mm.

    In Cura, go to FIle -> Preferences and select PronterFace as the Print Window UI. Then select File->Print to open the Pronterface UI. On the right there is a window that shows output from the printer. At the bottom of that window there is a small input box that is used to send commands to the printer.

    In the small input box, enter:


    and the printer will response with information about the current settings.

    Look for the value that is prefixed with Z under the heading "Steps per unit:"

    Without the HBK upgrade, the Z value for steps per unit is:


    With the HBK upgrade or the firmware for it, it will be:


    So if you use the HBK firmware but do NOT have the HBK, the firmware steps 200 steps for every 1 mm of Z movement where it should step 533.33 steps. The result will be that the height will be squashed to about 40% of normal.

    It's best to find and use the correct firmware. However, if you reflash the firmware you used before, you can probably correct it by copying the entire line under the "Steps per unit:" that begins with M92 and paste it into the small input box and then edit the Z value to be 533.33 and press return.

    Reissue M503 to ensure the value is set correctly.

    Then issue:


    which will save the settings in non-volatile memory.


  • Link to post
    Share on other sites

    Posted · upgrading firmware version squashes mesh

    Yes, you have most probably uploaded the 'wrong' firmware.

    As stated above, the HBK firmware is only for the official UM kit, with a different Z stage. You should not use that one if you have a custom heated bed (or no HB at all). There are other small changes related the official UM HBK in that firmware...

    (And for the 'normal' UMO, there have been very few changes in the firmware over the last year, so there is almost no reason to upgrade anyway. New version of Cura comes with new version of the firmware so that all versions are aligned, but it is basically the same code compiled with a new version number...)


  • Link to post
    Share on other sites

    Posted · upgrading firmware version squashes mesh

    Hey Guys,

    Thanks for the detailed replies.

    yeah i had selected the heated bed, turning the off and uploading fixed the issue, but created another.

    I have reverted back to my original build until i have more time for testing.




  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 6 replies
    • Create New...