Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

Can't get extruder and bed temperature value on printer lcd

Recommended Posts

Hello Daid,

have got till 2 days problem with using Cura.

Use Cura for lnear 2 years on my own printer. All works great. Temp parameter created by Cura on gcode file give perfect printing on printer in the past.

Till 2 days with stl download parts from imagine, thingiverse or design created and transformed in stl, i get sometimes on printer lcd screen , no temp bed (0°C) and extruder value (0°C), so can't print.

I use Cura gcode download on sd card directly.

Get sometimes the bed temp only(70°C or other temp i decide) and no extruder temp (0°C), so as i can adjust the temp on lcd screen for extruder to the value i want and it start printing but when get 0°C for both bed and extruder, nothing start even I change the temp setting on lcd screen. Temp increase as the value I notify but not print start.

When I can get some temp value, it's always the bed one. In no test i got the extruder temp only, just the bed one alone.

Have test with different stl files from different sources. Have check that gcode have been charged,, have used other computer, unistall Cura previous version and install others, still the same problem.

if i download on sd card gcode I have printed and saved in the past, all the bed and extruder temp are seen as they were previously; All is Ok.

I don't do programming. hope you can give me some links as to resolve this problem. I appreciate Cura, really very simple and perfect to be used but here i search all solution step by step to find the gap but all are not successfull.

Can't use my printer.

Hope you can help me in my Cura Graal search.


In this case


Share this post

Link to post
Share on other sites

Last 14.12.1

Have removed all other version as i think some problems between them.

Not specialist. If you have the info to change the start g.code will follow your tips.

Don't understand why before Ok. I download new version but the previous version I have worked for long time have done the same problems.

New version 14.12.1 give same pb.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 128 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!