Jump to content
ataraxis

STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

Recommended Posts

Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

I don't understand your question - and this is really an ultimaker forum, but here's a description of the RUMBA board;

http://reprap.org/wiki/RUMBA

Share this post


Link to post
Share on other sites
Posted (edited) · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

According to the information on http://reprap.org/wiki/RUMBA the little switches definitely represent the jumpers MS1, MS2 and MS3.

Thus you have to do exactly the same as described in the first post, the only difference is that you don't remove a jumper but simply turn the switch off.

That means:

 

  • First switch (that represents MS1) off (= state: "low")
  • Second off (= state: "open")
  • The third is irrelevant.

 

And... dont remove any pins.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

has anyone put these into a UM2 yet? is it even possible?

 

I would like to know this too!

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

The UM2 has its stepper drivers directly soldered onto the mainboard. This makes it more difficult (but not impossible) to use the SilentStepSticks.

You would basically have to remove the driver components from the board, then re-wire the TMC2100 on-the-fly. This is serious electronics tinkering, though. If you're not proficient with soldering and reading electrical schematics, then you'll have a very difficult time trying this...

There's also the matter of wiring the UM2 board's current control circuit to the TMC2100. Not sure if the circuits are compatible (didn't compare them in detail)...

  • Like 1

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

Hi, thanks for the great guide. I just successfully installed silent step sticks on X,Y,Z and E on my UMO. I have to say that this product is freakin awesome. My UMO is dead silent now :-)))

Share this post


Link to post
Share on other sites
Posted (edited) · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

This is a chinese clone of the actual SilentStepStick. No clue how it compares to the original... If they're actually using the same parts, then there shouldn't be any difference. But you never know with the Chinese...

You can get the Original here: http://www.watterott.com/en/SilentStepStick

/edit:

LOL

Looking at the pictures on aliexpress, you can see three things:

1. it's a different layout than the SilentStepStick (but not necessarily electrically different!)

2. There actually is a trinamic IC on the picture (good sign)

3. The soldering quality is HORRIBLE. This is really painful to watch, being an electronics engineer... The components look like they were thrown onto the board from a distance. The amount of solder is very uneven with lots of short-circuits on some and missing solder on other pads. This is definitely POOR workmanship. My advice: Do not buy.

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

Yeah, if you can get one that you have to solder yourself, that's an option to test. But I wouldn't assume it has the same performance without testing.

The problem of the original ones is that shipping is 10 euro :p

Share this post


Link to post
Share on other sites
Posted (edited) · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

[...] The problem of the original ones is that shipping is 10 euro :p[...]

 

I had also a tough time to accept the fee but finally ordered 4 of them a few minutes ago to make my UMO shhhhhh... :-)

Which heatsink / heat pad have you used???

I ordered this one:

http://www.watterott.com/de/Stiftkuehlkoerper-quadratisch-ICK-S-10-x-10-x-125

hope this is ok... but any hint appreciated :-)

Edited by Guest

Share this post


Link to post
Share on other sites
Posted (edited) · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

[...] The problem of the original ones is that shipping is 10 euro :p[...]

I had also a tough time to accept the fee but finally ordered 4 of them a few minutes ago to make my UMO shhhhhh... :-)

Which heatsink / heat pad have you used???

I ordered this one:

http://www.watterott.com/de/Stiftkuehlkoerper-quadratisch-ICK-S-10-x-10-x-125

hope this is ok... but any hint appreciated :-)

I think it will be just fine... Remember to mount it on the thermal pad on the bottom of the stick rather than directly on top of the IC

(But assuming you install the sticks correctly with bottom side up, nothing else makes sense anyways... its not like that heatsink will fit underneath the stick)

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

This is a chinese clone of the actual SilentStepStick. No clue how it compares to the original... If they're actually using the same parts, then there shouldn't be any difference. But you never know with the Chinese...

You can get the Original here: http://www.watterott.com/en/SilentStepStick

/edit:

LOL

Looking at the pictures on aliexpress, you can see three things:

1. it's a different layout than the SilentStepStick (but not necessarily electrically different!)

2. There actually is a trinamic IC on the picture (good sign)

3. The soldering quality is HORRIBLE. This is really painful to watch, being an electronics engineer... The components look like they were thrown onto the board from a distance. The amount of solder is very uneven with lots of short-circuits on some and missing solder on other pads. This is definitely POOR workmanship. My advice: Do not buy.

Isn't it also missing the thermal transfer pad (what do you call those), or is it just painted over? I cant tell from the pics...

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

They just forgot to free the pad.

But then they also used too large vias which wick away the solder paste from the IC's pad. Whoever designed that driver didn't care much about "details"...

You can just put the heatsink on them regardless. Heat transfer will be worse, but should still be somewhat functional.

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

[...] finally ordered 4 of them a few minutes ago to make my UMO shhhhhh... :-) [...]

 

Got my SSS today but ... I´m such an idiot... I ordered 4 of them but have 2 extruders beside XYZ... so one too less... DAMN...

Next issue: one of them came with a damaged ESD packaging... so we´ll see if I have to claim it or not...

:(

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

I finally installed my silentstepsticks and so far I'm quite happy with it (especially the noise or lack there of!). my x-axis was acting up though during a test print. I have two shifts of around 10mm, once to the right and a little later to the left. What could be the cause of this? I have just installed direct drive and GT2 belts, movement is butter smooth... maybe a faulty chip? any ideas? VREF is set to around 1.3V right now. Can it be too high?

IMG_5559.thumb.jpg.c50d4f83377b40a0fbe5d347d86dafee.jpg

IMG_5559.thumb.jpg.c50d4f83377b40a0fbe5d347d86dafee.jpg

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

never mind. I misread, VREF should be a bit over 1.6V, I'll try later and come back with the results ;)

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

the chips are now tuned to around 1.6V (turning the potentiometer clockwise) and my printer is now actually behaving worse. How can that be? I followed the instructions really closely, MS1, MS2 and MS3 are disconnected, the firmware updated correctly. My first test print is perfect until the moment when I lost lots of steps.

has anyone of you got a clue how I could solve that? maybe it has happened to someone else, too? asmentioned, the mechanics of the printer are flawless (imho).

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

 

[...]  finally ordered 4 of them a few minutes ago to make my UMO shhhhhh... :-) [...]

 

Got my SSS today but ... I´m such an idiot... I ordered 4 of them but have 2 extruders beside XYZ... so one too less... DAMN...

Next issue: one of them came with a damaged ESD packaging... so we´ll see if I have to claim it or not...

:(

 

Just leave the z-axis with a a4988 or whatever is in there now... You CAN get the machine to home the z-axis more quietly with a SilentStepStick, but that is about it... The effect while printing is negligible at most...

regarding the ESD packaging, I would be surprised if it has caused any sort of damage to your stick (that is assuming whatever damaged the packaging didn't ALSO damage the stick...), I have never taken much care with any of the numerous stepsticks I have lying around, and never saw any faults related to that...

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

the chips are now tuned to around 1.6V (turning the potentiometer clockwise) and my printer is now actually behaving worse. How can that be? I followed the instructions really closely, MS1, MS2 and MS3 are disconnected, the firmware updated correctly. My first test print is perfect until the moment when I lost lots of steps.

has anyone of you got a clue how I could solve that? maybe it has happened to someone else, too? asmentioned, the mechanics of the printer are flawless (imho).

 

1.6V for vref sounds very high... You should start at around 0.8V and move upwards slowly, testing motor strength between each adjust.... Arent your motors and sticks getting crazy hot with the 1.6V setting?

You also mention having recently switched to GT2 pulleys... For good measure, double check that all pulley screws are tightned properly... You can check for slip by marking the grub screw position on your axis with a magic marker... after a print where your shifting layers have occured, check the marks to see if they are still aligned with the screws.

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

Just leave the z-axis with a a4988 or whatever is in there now... ... The effect while printing is negligible at most...

Thanks for onfirming my (unwritten) assumption :-)

 

regarding the  ESD packaging, .... and never saw any faults related to that...

 

Already got an similar answer from Watterott - I´ll use them and we will see.

Had some troubles with more sensitive parts in future where the packing was damaged, so safety first :-)

I will post my experience as soon I have time to upgrade...

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

hey tommy

thanks for your reply! You were right, voltage was way too high. I recently changed my electronics cooling to 2x40mm fans. It seems even a VREF of 1.25V caused the drivers to overheat. I have now tuned them back to around 0.85V and printing is flawless, at least for a 30 minute print. I'll now try a longer print and see wether I might have to improve cooling. I also just reused the heatsinks of my old drivers because the aluminium ones I ordered were too high ;).

I'm now incredibly happy with my setup, direct drive, GT2 and the new drivers make a huge difference to my printing experience and should also decrease maintenance a bit. Less moving parts is always great!

Share this post


Link to post
Share on other sites
Posted (edited) · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

hey tommy

thanks for your reply! You were right, voltage was way too high. I recently changed my electronics cooling to 2x40mm fans. It seems even a VREF of 1.25V caused the drivers to overheat. I have now tuned them back to around 0.85V and printing is flawless, at least for a 30 minute print. I'll now try a longer print and see wether I might have to improve cooling. I also just reused the heatsinks of my old drivers because the aluminium ones I ordered were too high ;).

I'm now incredibly happy with my setup, direct drive, GT2 and the new drivers make a huge difference to my printing experience and should also decrease maintenance a bit. Less moving parts is always great!

 

Great you got it working :)

When you say the heatsinks you ordered were too high, do you mean to fit under whatever cooling fan mount thingy you have sitting over your electronics?

Im asking to make sure you put everything in correctly... Sticks should go in with "component side" facing down, and the heatsink installed on the little thermal pad on the back (now facing up).

I myself have two Fractal Design - Silent Series 40mm. fans cooling my electronics... It's a Rumba board and the fans are centered over the stepsticks... I have never had a problem with cooling with that setup, so I think you will be fine too :)

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

hi tommy

no worries, I mounted the sinks correctly. I meant the sinks I ordered don't fit into ultimakers fan 'channel' design (the plywood that channels the cooling air over the stepper boards). I might have to redesign that part anyway though...

I'm using this design at the moment: https://www.youmagine.com/designs/ultimaker-replacement-electronics-fan

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

... I meant the sinks I ordered don't fit into ultimakers fan 'channel' design (the plywood that channels the cooling air over the stepper boards). ....

 

Which one have you ordered? Those nice alu ones from Watterott (http://www.watterott.com/de/Stiftkuehlkoerper-quadratisch-ICK-S-10-x-10-x-125) or other ones?

Just to be aware of when starting exchanging mine...

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

yes, the nice alu ones are way too big. the other ones are not in stock right now, they would probably fit, though...

Share this post


Link to post
Share on other sites
Posted · STEP-BY-STEP: Installation of SilentStepStick-Drivers on UMO

Hey yoveo!

I added the overheating, caused by a too high voltage, to the instruction - thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!