Jump to content
Ultimaker Community of 3D Printing Experts

Taking awhile to extrude at start of print

Recommended Posts

Posted · Taking awhile to extrude at start of print

I have a new Ultimaker2. I had not trouble setting it up. The bed calibration was much easer that with my da Vinci. I printed the robot test print and all worked as expected.

The next print that I made, it took some time for the filament to extrude. It did not print the skirt and it was halfway through the first layer before it started to lay down plastic. It finished printing and the print looked fine, just some buggers, and the problem with the first layer, but not bad.

I went to print the next print, and I watched it to see if it would print the skirt. When it started it did not print the skirt, so I stopped it.

I am using Cura 15.02.1. I checked my settings and tried again. the same thing happened. I could see that the filament looked like it was feeding, but it was not coming out. I stopped it again, and checked my settings. I noticed that the retract was set to 4.5mm, and the pre-feed was set to 3mm. I thought that what was happing was the filament was not getting to the print head before it started to print.

Just a side note. When the robot was printing, the print head moved to the front left and ran out some plastic. It then start the skirt and the robot. I am not sure why this is not happening with my prints. The print head moves immediately to print the skirt.

Back to my story. I adjust the pre-feed to 5mm, thinking this would move the filament up to the print head. But it did the same thing, and I stopped it.

I then noticed that I could see the end of the filament in the tube. So I manually fed the filament until it was coming out of the print head, and then started the print. It printed the skirt and then started the print.

With the next print the same thing happened. I moved to print the skirt and it did not lay down plastic. I stopped and manually fed the filament until it was coming out and then start the print.

My question is, am I doing something wrong with Cura that is causing it not to extrude the filament before it starts to print?

I have not used Cura before. I use Slic3r with my da Vinci. This print is still not printing wright. I am having trouble with the supports.

Thanks for any advice.


  • Link to post
    Share on other sites

    Posted · Taking awhile to extrude at start of print

    I come from davinci too. On umo+ happens the same (but I just can turn the extruder manually. Cura retracts 5 at the end of a print and extrude 3 at the start (check Gcode start/end) It's normal to not push filament just at the start. I like this since it leaves only the minimum on the head cooling after a print and at the start of a print it's always good yo use a brim or a skirt. You can change the start gcode con cura on expert settings and adjust the numbers as you see fit. I changed mine to retract 15 at the end of a print. This way I can always change the filament without heating the nozzle. And I just push it manually at the start of a print. You could change the start to push more at the start changing that.

  • Link to post
    Share on other sites

    Posted · Taking awhile to extrude at start of print

    You can do the same on the UM2. I usually give a little push on the filament toward the feeder (it works as long as the extrusion as not started). I personally feel the end of print retraction is too long and sometimes it causes the filament to stay stuck between the insulator and the heater block.

  • Link to post
    Share on other sites

    Posted · Taking awhile to extrude at start of print

    Hi guys if you use a laptop to drive your printer then you will find it easier to install RepetierHost or, I suspect, Pronterface both are free. They give you more easy control over the printer, both before and during the print. One function is manually extruding filament before starting the print - all you do is hit a button on the GUI. I always extrude around 30mm before starting the print to make sure it is flowing nicely and there are no issues.


  • Link to post
    Share on other sites

    Posted · Taking awhile to extrude at start of print

    Thanks guys for the feedback.

    I think that I have found the problem. When I first got my da Vinci I was not happy with the slicer that XYZ provided. I started to look for a better slicer. I had installed Cura and set it up for the da Vinci. Did not like it, and went to something else. Well when I received my Ultimaker2 I just updated the version of Cura started using it. Cura was still setup for the da Vinci. The first thing that tipped me off was the view did not show the bed clips. When watching videos of people using Cura, their were clips in the view of the print surface. I uninstalled Cura and removed all traces of it, then reinstalled. Now it comes to the front left and spits out some filament before it starts to print. Live and learn.

    Just as a side note, are you guys happy with Cura, I am so uses to Slic3r that I miss some of the controls.

    Thanks again.


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    • Create New...