Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
maybites

Extruder Motor not working

Recommended Posts

Hi

I just completed the construction of my new ultimaker and everything worked fine. I was able to use ReplicatorG's ControlPanel to control all motors, including the extruder motor, and was able to extrude some material as well. but after I tried to print out the first model (I followed the steps in

http://wiki.ultimaker.com/Newcomer_guid ... t_3D_print

) the extruder motor stopped working when the print job started. And now I am not able to control it anymore via ControlPanel. The motor itself works fine - I attached it to the Z-axis motor plug for testing.

Update: Now I am able to control the motor, but only if I unplug the usb and restart the ReplicatorG after trying to printout the model.

cheers

martin

Share this post


Link to post
Share on other sites

Sounds like you have two problems we need to sort out:

1) Extruder motor does not work during the 'build' process.

2) Extruder motor does not work in manual control mode.

Problem 1)

It's hard to track down the problem based on the opening post. Answering Daid's questions will help to get to a solution.

Problem 2)

There are some known issues in Manual control mode in RepG with the extruder motor. Responsiveness of the extruder's buttons is really bad for some reason. The extruder motor should work just fine in 'build mode' though. Your non-running motor may be related to problem 1 but it might as well be this known issue...

M

Share this post


Link to post
Share on other sites

First Daids question:

The ReplilcatorG says: "Machine Ultimaker v1.0 (ADVISED 5D firmware) ready"

ReplicatorG 0025 for OSX

2) seems to be not the most pressing issue anymore since I can reset the machine and using the controlpanel again (I actually plugged the motor into the wrong plug after my test).

1)I posted the first lines of GCode here:

http://pastebin.com/EUgErEYj

 

Share this post


Link to post
Share on other sites
1)I posted the first lines of GCode here:

http://pastebin.com/EUgErEYj

 

Great. That also instantly shows what's wrong. Many of those "G1" commands should have an E value (E controls the extruder motor)

Which is most likely caused by the "Dimension" plugin not enabled. So you'll need to enable it. (Quick guide: Open RepG, press "generate GCode", press "edit", open "dimension" tab, enable it, save all settings)

Share this post


Link to post
Share on other sites

No Success. I followed the given instructions and enabled the dimension plugin (Activate Dimension inside Skeinforge Settings) and the E Values dont appear.

 

G21 (This is GCode, generated with Skeinforge version 35 from ReplicatorG)G21 (Ultimaker profile - Quality print - alterations/start-centered.gcode)G21 (Metric: The unit is a millimeter)M18 (Disable motors for now, to allow manual moving of the head)G90 (Absolute Positioning)G92 X0 Y0 Z0 E0 (set origin to current position)M1 (Check if the platform is empty before continuing)G1 X-220.0 Y-220.0 F2000 (ensure you're in the front left corner)G92 X-110 Y-110 Z220 E0 (make the center the origin)G1 X0.0 Y0.0 F3000 (go back to the center)G1 Z210.0 F100 (let the platform go up slightly, start slowly)G1 Z0.0 F400 (we don't have all day...)G92 X0 Y0 Z0 E0 (make the center the origin)G91 (Relative positioning)G1 Z35.0 F400 (lower platform for cleaning nozzle)G92 E0 (zero the extruded length)G1 E260 F1000 (extrude some to get the flow going)G1 E-20 F3000 (reverse a little)G92 E0 (zero the extruded length)M1 (Clean the nozzle and press YES to continue...)G1 Z-1.0 F100 (rise platform again)G1 Z-34.0 F400 (rise platform again)G90 G1 Z0.4G92 E0 (zero the extruded length)G21 (end of start .gcode file)G90G21;M103M105M106M140 S60.0M141 S30.0M142 S0.0M113 S1.0;M108 S50.04M104 S220.0M104 S218.096;M108 S37.53G1 X-11.02 Y-0.31 Z0.3 F60.0G1 F798.0;G1 E0.0G1 F60.0;M101G1 X-11.02 Y-10.19 Z0.3 F1800.0 E12.361G1 X-10.98 Y-10.36 Z0.3 F1800.0 E12.576G1 X-10.8 Y-10.67 Z0.3 F1800.0 E13.027G1 X-10.52 Y-10.9 Z0.3 F1800.0 E13.48G1 X-10.19 Y-11.02 Z0.3 F1800.0 E13.919G1 X10.19 Y-11.02 Z0.3 F1800.0 E39.415G1 X10.36 Y-10.98 Z0.3 F1800.0 E39.63G1 X10.67 Y-10.8 Z0.3 F1800.0 E40.081G1 X10.9 Y-10.52 Z0.3 F1800.0 E40.533G1 X11.02 Y-10.19 Z0.3 F1800.0 E40.973G1 X11.02 Y10.19 Z0.3 F1800.0 E66.468G1 X10.98 Y10.36 Z0.3 F1800.0 E66.684G1 X10.8 Y10.67 Z0.3 F1800.0 E67.134G1 X10.52 Y10.9 Z0.3 F1800.0 E67.587G1 X10.19 Y11.02 Z0.3 F1800.0 E68.027G1 X-10.19 Y11.02 Z0.3 F1800.0 E93.522G1 X-10.36 Y10.98 Z0.3 F1800.0 E93.737G1 X-10.67 Y10.8 Z0.3 F1800.0 E94.188G1 X-10.9 Y10.52 Z0.3 F1800.0 E94.641G1 X-11.02 Y10.19 Z0.3 F1800.0 E95.08G1 X-11.02 Y0.11 Z0.3 F1800.0 E107.689G1 F798.0G1 E107.689G1 F1800.0;M103M104 S220.0;M108 S50.04M104 S218.096G1 X-11.4 Y0.11 Z1.0 F68.353G1 X-11.4 Y10.23 Z1.0 F2400.0G1 X-11.34 Y10.49 Z1.0 F2400.0G1 X-11.23 Y10.71 Z1.0 F2400.0G1 X-11.09 Y10.91 Z1.0 F2400.0G1 X-10.91 Y11.09 Z1.0 F2400.0G1 X-10.71 Y11.23 Z1.0 F2400.0G1 X-10.49 Y11.34 Z1.0 F2400.0G1 X-10.23 Y11.4 Z1.0 F2400.0G1 X10.23 Y11.4 Z1.0 F2400.0G1 X10.49 Y11.34 Z1.0 F2400.0G1 X10.71 Y11.23 Z1.0 F2400.0G1 X10.91 Y11.09 Z1.0 F2400.0G1 X11.09 Y10.91 Z1.0 F2400.0G1 X11.23 Y10.71 Z1.0 F2400.0G1 X11.34 Y10.49 Z1.0 F2400.0G1 X11.4 Y10.23 Z1.0 F2400.0G1 X11.4 Y-10.23 Z1.0 F2400.0G1 X11.34 Y-10.49 Z1.0 F2400.0G1 X11.23 Y-10.71 Z1.0 F2400.0G1 X11.09 Y-10.91 Z1.0 F2400.0G1 X10.91 Y-11.09 Z1.0 F2400.0G1 X10.71 Y-11.23 Z1.0 F2400.0G1 X10.49 Y-11.34 Z1.0 F2400.0G1 X10.23 Y-11.4 Z1.0 F2400.0G1 X-10.23 Y-11.4 Z1.0 F2400.0G1 X-10.49 Y-11.34 Z1.0 F2400.0G1 X-10.71 Y-11.23 Z1.0 F2400.0G1 X-10.91 Y-11.09 Z1.0 F2400.0G1 X-11.09 Y-10.91 Z1.0 F2400.0G1 X-11.23 Y-10.71 Z1.0 F2400.0G1 X-11.34 Y-10.49 Z1.0 F2400.0G1 X-11.4 Y-10.23 Z1.0 F2400.0etc..

 

Share this post


Link to post
Share on other sites

Did you try to print that GCode? Because it does show E values for the first set of G1 codes. The other set of G1 codes might be cooling (Set the cool plugin to "slowdown" instead of "orbit" with a time of minimum layer time of 10 seconds). I also recommend you disable the "temperature" plugin, and just preheat yourself before printing.

Share this post


Link to post
Share on other sites

It works now after making these changes! It prints now, expcept it seems as if the default settings dont provide enough material-feed. but thats a different issue.

Thank you very much for your speedy suggestions to my problem. I really appreciate it.

martin

Share this post


Link to post
Share on other sites

You're welcome.

The feed issue could be mechanical, not settings.

For me on my first prints the hobbed bolt was slipping on the large gear. So the gear was turning, but it was not really pushing the filament. So check that the bolt is rotating at the same speed as the gear. Then you could also check if the filament itself slips (and tight that screw a bit, but don't tight it to much!)

Then again, it could be the feedrate settings. Upgrading to Marlin with SF41 or higher is highly recommended so you can use the filament diameter instead of the kinda awkward feedrate settings. (Skeinforge_pypy: viewtopic.php?f=8&t=153 is also an option, it has all the settings pre-configured for the ultimaker, but it's still a bit experimental)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 0 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!