Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker 2 Error - Stopped: X or Y switch stuck

Recommended Posts

Hi @kpk, could elaborate on your problem?

Lets focus on this issue here, and focus on the temp error in the other thread.

How do you mean stuck?

If we don't have more information we can only guess to what the problem might be and it is not an efficient use of anyones time.

If you think uploading a video would help, please upload it.

Have you checked out our support pages?

Share this post

Link to post
Share on other sites

I think you still have an older firmware version that contains this error message. It has been there for a short while, but since it didn't add much value it has been removed again.

So I would advise to check the firmware on your Ultimaker and make sure you install the latest one. Hope it works!

Share this post

Link to post
Share on other sites


The temperature sensor error is solved right now.

When i started the machine , and clicked on home position it went to home position and started vibrating and parallely i got error on the screen that X or Y axes stuck.

I am not getting how to resolve this , as you already said is there any disturbance due to transportation, but according to me there is no such misalignment but it vibrates and makes loud sound like something is grinding inside.

Share this post

Link to post
Share on other sites

Have you checked the pulleys are tight on the shafts ? are the short belts nice and tight (motor's not lose) ?

Are the limit switches actually being activated when the head is in the home position ? you should here them click if you move the head by hand to the home position ?

Edited by Guest
  • Like 1

Share this post

Link to post
Share on other sites

I don't think the pulleys are loose, because judging from the sound it makes it is hitting the side. If the pulleys were loose, the rods would most likely rotate in the loose pulley over the motor skipping steps. (it requires quite some friction to do this).

I guess the limit switch error could be solved by uploading the firmware.

You could also check if the cable is still fully inserted in the electronics.

Check if the wires of the limit switch don't show any wear due to the pulleys.

A workaround to check if the limit switches work:

Place the printhead in the front right corner.

Press home, while homing (you have to be fast) use a pen or pencil to manually press the limit switch, you can find on your back right corner.

If by pressing it, your print head doesn't stop moving there is physically something wrong with your limit switch.

If it does work and the head stops moving, the limit switch is fine and the error is something else. Like firmware.

Looking forward hearing from you.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 130 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!