Jump to content
Ultimaker Community of 3D Printing Experts

Problems at Upload Marlin v1.0.0 RC3


goodwell

Recommended Posts

Posted · Problems at Upload Marlin v1.0.0 RC3

Hi,

I wanted today the current marlin firmware on my UM load, but because I get no display more on my Ulticontroller and nothing else works.

At the moment I have the RC2 on it, that works.

Must I change something before I upload?

And what are for warnings and error messages when compiling the firmware with arduino 1.0.1?

  • Link to post
    Share on other sites
    Posted · Problems at Upload Marlin v1.0.0 RC3

    Also those warnings are a bug in gcc, and workarounds applied caused other problems. The real solution is to upgrade your gcc version.

    The most logical reason why your UltiController no longer works is because you did not enable it in the Configuration.h

  • Link to post
    Share on other sites
    Posted · Problems at Upload Marlin v1.0.0 RC3

    Ahhrg.... just there was still what.Man because I otherwise always remember thought and this time totally overlooked.

    I will probably slow blind with age.

    Thanks Daid for your fast and Quick answer.

    I use Arduino 1.0.1 as gcc i think it is up to date , or isn´it? (Date 21.05.2012)

    Or does you use an other gcc?

  • Link to post
    Share on other sites
    Posted · Problems at Upload Marlin v1.0.0 RC3

    Dates say little. The avr-gcc I use is version 4.6.2

    I know for certain that Arduino 1.0 came with an older version. And when I tried to compile Marlin with Arduino-1.0.1 yesterday the compiler was throwing strange errors.

    (The actual recommended version of Arduino to use is 0.23)

  • Link to post
    Share on other sites

    Archived

    This topic is now archived and is closed to further replies.

    ×
    ×
    • Create New...