Jump to content

looming

Member
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. At last, I solve the build error. These are what I do: 1.Fix the import : Remove "import Queue" 2.Fix thread model of UI: Add an annotation "@call_on_qt_thread" to the function. Maybe this method "model.setItemData" can only call from MainThead from cura.Utils.Threading import call_on_qt_thread @call_on_qt_thread def update_history_ip(self): ... model.setItemData(model.createIndex(i,0), {1:"",0:"False"}) These are what I do, but maybe not with regard to the build error: 1.Rename the package from "FlyingBearPlugin" to "FlyingBearIntegration" 2.Remove " .gitignore" from the zip file 3.Remove my custom stage, and create an "Extension" to open a new window.
  2. I make a plugin, and I put it into the plugin folder of Cura 4.0 or 4.1, it works well. When I upload plugin in Contributor Portal, these is a Error message: One of the required files could not be found. It seems some files missed. How can I know which files missed? Attachment file is my cura plugin FlyingBearPlugin.zip
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!