Jump to content
Ultimaker Community of 3D Printing Experts

zhutwo

Member
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Yes, it would be an if statement to check if an extruder is enabled before setting its temp. Enabling/disabling an extruder in Cura is kind of a setting, so I was hoping it would be a thing.
  2. What defines the hot end as active? As far as I can tell, disabling an extruder in Cura doesn't change the code output.
  3. Hi, I posted a reply in another thread about the Qidi X-Pro regarding this, but since this might be a discovered bug, I'm making a thread to bring attention to it. So the problem is that if you have a dual extruder printer like the Qidi X-Pro and you only want to print using one extruder, Cura (v4.7.1 in my case) will output code that heats up both extruders, which can result in warping if the 2nd extruder passes over material for a prolonged period. This occurs even if you disable the other extruder, attempt to set its material temp to 0C, or even force its temp to 0C
  4. zhutwo

    Qidi X-pro

    Hi, I have this same problem and after snooping around the generated g-code file I found that Cura (v4.7.1 in my case) was outputting M104 S200 at the end of the LAYER 0 instruction set. This causes both extruders to be set at 200C after the initial layer is finished printing. Since my start code already sets the temperature, simply removing this line of code fixes the issue. Adding T<extruder index> to the end would make it only affect the desired extruder. I don't know why Cura doesn't automatically check for the inactive extruder and modify the output
×
×
  • Create New...