Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
inx

Help with Cura on OSX 10.7.4 - slicing errors

Recommended Posts

Hello.

I have problems slicing a model in cura 12.08 using Mac osx 10.7.4.

when i try to "Slice to GCode" i get an error saying:

"Something went wrong during slicing!", the log reveals:

-------------------------

File /Applications/ReplicatorG/examples/hexagon.stl is being chain exported.

Exception traceback in getModuleWithDirectoryPath in archive:

Traceback (most recent call last):

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/archive.py", line 244, in getModuleWithDirectoryPath

folderPluginsModule = __import__(fileName)

File "/Applications/Cura-12.08/Cura/cura_sf/skeinforge_application/skeinforge_plugins/craft_plugins/carve.py", line 107, in

from fabmetheus_utilities import svg_writer

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/svg_writer.py", line 14, in

from fabmetheus_utilities.xml_simple_reader import DocumentNode

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/xml_simple_reader.py", line 35, in

from fabmetheus_utilities.geometry.geometry_utilities import evaluate

File "/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/geometry/geometry_utilities/evaluate.py", line 10, in

from fabmetheus_utilities.geometry.geometry_utilities.evaluate_elements import setting

ImportError: No module named fabmetheus_utilities.geometry.geometry_utilities.evaluate_elements

That error means; could not import a module with the fileName carve

and an absolute directory name of /Applications/Cura-12.08/Cura/cura_sf/skeinforge_application/skeinforge_plugins/craft_plugins

-------------------------

i tried various python 2.7.3 versions: the osx-shipped python 2.7.3, macports python 2.7.3 and the one manually installed one...

with all versions i get the same error.

what is wrong?

tanks for any help.

inx

Share this post


Link to post
Share on other sites

Yes.

The file evaluate.py and evaluate_elements folder exists under these pathes:

/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/geometry/geometry_utilities/evaluate.py

/Applications/Cura-12.08/Cura/cura_sf/fabmetheus_utilities/geometry/geometry_utilities/evaluate_elements

Content of evaluate_elements is:

-rw-r--r--@ 1 inx staff 0 Jul 6 14:34 __init__.py_

-rw-r--r--@ 1 inx staff 2110 Apr 3 2012 creation.py_

-rw-r--r--@ 1 inx staff 3132 Apr 3 2012 document.py_

-rw-r--r--@ 1 inx staff 6751 Apr 3 2012 setting.py_

___

inx

Share this post


Link to post
Share on other sites

i was wondering about these underscores... but left them on.

just unpacked the package osx64-Cura-12.08.tar.gz again using "The unarchiver version 3.3", browsing to the same folder shows me the files with underscores...

unpacked them via command-line and the underlines are not there...

so "The Unarchiver" did manipulate the files?!

Tried again unzipping the tar.gz in the command-line first, and then using "The unarchiver" with the left over .tar file.

This did work.

weird.

Using the freshly unpacked archive without underscores worked.

Thanks!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!