Jump to content
Ultimaker Community of 3D Printing Experts
Titus

*solved* Can't talk to UMO/Arduino

Recommended Posts

Edit: This post now serves as guide for others with the same problem. Skip down for solution

Hi all,

Today I wanted to check for firmware updates/reload firmware to get default accelerations values(in case that was causing the print trouble). I also wanted to level my bed using Cura.

But, couldn't connect to printer. My computer made the hardware connected sound, it shows in device manager, but my UMO never did the Bzzzt + white squares routine it does when connected over USB. Tried multiple computers, multiple cables, different Cura versions, nothing. Troubleshooting pages on the site suggested taking Arduino off the shield. Didn't help either.

The Arduino Mega 2560 (COM3) shows in Device monitor. Uninstalled drivers, reinstalled using Cura.

Went for manual firmware upload through Arduino IDE, it sees COM3, it recognizes Arduino Mega 2560, but when uploading, error:

avrdude: ser_open(): can't open device "\\.\COM3": The device is not connected.

avrdude: ser_drain(): read error: The handle is invalid.

The thing is, my printer actually still "works". But I just want it to be able to talk to my computer. I know I can level using other ways, but for firmware updates, Protoface UI testing etc etc.

I searched the forum, and the internet, found different topics of people who seem to have bricked their Arduino, but nothing similar. Help!

 

EDIT

Ofcourse a minute later I find this post with some random procedure that works.... I suspect somehow somewhere something was mysteriously also occupying COM3. HOWEVER, it was also the case on my laptop, which makes me think it was something inside the Arduino. Though I have no clue what it could be. Anyway, I followed the procedure and picked a high number @ step 8. Now Cura talked to the Arduino and I could upload firmware etc.

1. device manager

2. select ports

3. select port of arduino board examle : com1 ... com3 whatever it is

4. right click on com.

5. select properties

6. tab- port settings

7. click advanced

8. com port number- select new port number that is not in use.

9. confirm..

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Print Core CC | Red for Ruby
      Q: For some users, abrasive materials may be a new subject matter. Can you explain what it is that makes a material abrasive when you are not sure which print core to use?
      A: Materials which are hard in a solid piece (like metals, ceramics and carbon fibers) will generally also wear down the nozzle. In general one should assume...
      • 1 reply
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!