Jump to content
Ultimaker Community of 3D Printing Experts
D4fnk

Octoprint & pre printing options ?

Recommended Posts

Hey,

I just started using Octoprint to monitor and control my Ultimaker 2 Extended+ but i have an issue : when i start a printing from Octoprint there is no warmup (either bed or nozzle) and no first layer for the print, it starts the object directly. I switched to RepRap (Marlin/Sprinter) in Cura but it didn't change anything. Also, i have no issue at all when printing from the SD.

I googled it and it seems that there are no way to automatically pre heat the nozzle/bed and extrude some filament (i.e starting the same way as a print from the SD card) and that i have to do it manually for each print, can anyone confirm ?

Or is there a possibility to script it in the Before Print options ?

Thank you

Share this post


Link to post
Share on other sites

If you set Cura to RepRap (Marlin/Sprinter) it should generally work. Make sure it uses something like this as the start gcode:

 

G21 ;metric values

G90 ;absolute positioning

M82 ;set extruder to absolute mode

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

G28 Z0 ;move Z to min endstops

G1 Z15.0 F{travel_speed} ;move the platform down 15mm

G92 E0 ;zero the extruded length

G1 F200 E3 ;extrude 3mm of feed stock

G92 E0 ;zero the extruded length again

G1 F{travel_speed}

M117 Printing... ;Put printing message on LCD screen

 

Alternatively you can also add this to the beginning of your .gcode file.

If you are using Cura 2.1, check your machine's .json file found in "C:\Program Files\Cura 2.1\resources\machines".

Hope this helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy