Jump to content

Finished Part Z thickness


nigelwebb

Recommended Posts

Posted · Finished Part Z thickness

I am trying to resolve a Z thickness of the finished part issue with Cura 2.1.2

I have created a part that is 3mm thick, and 5x10mm in size, just for demo purposes.

I am printing with a Raft, I want to keep the Raft, so don’t suggest printing on the glass plate because this issue also affects the support structure, however I will leave that issue out for now to keep this simple.

0.4mm nozzle, ABS, Normal Quality 0.1mm layers

Turning on Raft,

Raft Air-gap 0.3

Initial Layer Z Overlap 0.15 (box is coloured yellow for some reason?)

Raft Top Layers 2

Raft Top Line Width 0.3

Raft Top Spacing 0.3

The gcode is like this (I have summarised this)

;Generated with Cura_SteamEngine 2.1.2

;LAYER_COUNT:30

;LAYER:-4, Z0.300, ;TYPE:SUPPORT

;LAYER:-3, Z0.570, ;TYPE:SUPPORT

;LAYER:-2, Z0.670, ;TYPE:SUPPORT

;LAYER:-1, Z0.770, ;TYPE:SUPPORT

;LAYER:0, Z1.340, ;TYPE:WALL-INNER

;LAYER:1, Z1.290, ;TYPE:WALL-INNER

;LAYER:2, Z1.390, ;TYPE:WALL-INNER

;LAYER:3, Z1.490, ;TYPE:WALL-INNER

;LAYER:29, Z4.090, ;TYPE:WALL-INNER

From Layer -1 Z0.770 to Layer 29 Z4.090 the difference is 3.32mm , which happens to be the exact thickness of the part when measured with a vernier. However the model thickness is 3.00mm

Note also Layer 1 being lower than layer 0? - This is due to the Initial Layer Z offset which I guess is why it is yellow!

If I change ‘Initial Layer Z Overlap’ to 0

;Generated with Cura_SteamEngine 2.1.2

;LAYER_COUNT:30

;LAYER:-4, Z0.300, ;TYPE:SUPPORT

;LAYER:-3, Z0.570, ;TYPE:SUPPORT

;LAYER:-2, Z0.670, ;TYPE:SUPPORT

;LAYER:-1, Z0.770, ;TYPE:SUPPORT

;LAYER:0, Z1.340, ;TYPE:WALL-INNER

;LAYER:1, Z1.440, ;TYPE:WALL-INNER

;LAYER:2, Z1.540, ;TYPE:WALL-INNER

;LAYER:3, Z1.640, ;TYPE:WALL-INNER

;LAYER:29, Z4.240, ;TYPE:WALL-INNER

Now the part is 0.15mm thicker (Layer 1 Z0.770 Layer 29 Z4.240 = 3.47mm), as expected. But it’s not 3.0mm as desired.

So to solve this I need to make the Z Overlap value 0.45mm, which really messes up Layer 0 (Z1.340) & Layer 1 (Z0.990).

Is there a way to solve this by removing the layers that are not required due to the Raft Air Gap rather than offsetting down the next layers?

Thanks

Nigel

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...