Jump to content

Cura files crashing Marlin


Recommended Posts

Posted · Cura files crashing Marlin

Hey all, newb to the community here. Finally had to admit that I need some expert help. 


TL/DR: I flashed Marlin 1.1.x to my Tevo Tarantula after hitting a wall with troubleshooting failed prints and trying several Cura versions. Now gcode files from Cura 3.2.1 are crashing when trying to print, rebooting the firmware. Gcode attached. 




I troubleshoot electronic devices for a living, so I'll try to include all the relevant details here. 


Last summer I built a Tarantula kit (regular bed, no auto-level) and started printing. I've been designing in Fusion 360 (2.0.3803) on my MacBook Air running Sierra (10.12.3), and started out slicing in Cura 2.6.2. For 6 months, my prints got better and better as I dialed things in and learned what kind of settings worked best with my printer and filament. Through that time, I kept the stock MigBot firmware installed. About a month and a half ago, I updated to Cura 3.1 to use a few new features. Prints went as expected for a few weeks. One day after playing with the settings preferences for combing and rafts (not actually trying to print, just enabling the options), every file I tried to print started failing. The printer would no longer warm up, nothing moved, and the print progress percentage just kept going up until it got to the last layer, at which point the z axis would rise to the top layer height and print the last layer into thin air, then showed that the print was complete. 


For troubleshooting that issue, I printed an older file on my SD card, which printed perfectly. That pointed me back to Cura. I disabled the settings options I had played with, created a new printer profile with fresh settings, deleted and reinstalled Cura from the website, and finally cleared the entire Cura folder from my Mac's application support folder to run it without a shred of my old settings, restarting and testing between each step. At that point, I started a reddit thread for help. That lead to examining the gcode files, and there were some differences in the code near the beginning. I rolled Cura back to 2.7, used all of my old settings and configurations for the printer and the options in Cura, same issue. 


Today I finally got back to troubleshooting. I started with flashing Marlin 1.1.x with the Jim Brown tarantula customizations from GitHub. I made sure to print a calibration cube file I had on the SD card to make sure the firmware worked properly, it looked even better than the last ones I've done. I went ahead and installed Cura 3.2.1, using the included tarantula profile. So, fresh start with all software. I loaded an STL file from thingiverse this time, instead of one of my own designs. Set everything to settings I know work well on my printer, saved the file to the SD card, and gave it a whirl. Now every time I try to print one of these newly sliced gcode files, the printer crashes and reboots. 


I expect this is still Cura related, but for the life of me I can't figure out why. I'm attaching the gcode files from a known good calibration cube, and one from today that's not working. There are some differences, but now that I've gone to Marlin firmware, the flavor is different so I don't know what to tweak. I will mention, even though I hear good things, the tarantula group on Facebook isn't an option for me as I've deactivated my account. 


Any help or advice is appreciated, and apologies for the novel of a post. 



Failing Cube.gcode

Known good Cube.gcode

  • Link to post
    Share on other sites

    Posted · Cura files crashing Marlin

    Update: I've been editing the start gcode using some of my old prints. Using the text editor on my Mac I've noticed that sometimes files are exported from Cura with the entire code, other times when I try to view them they are completely blank even though the file size looks correct. If I save the same file to my desktop and view it from there, it's full of text. Copy that over to the SD card and it's blank again. While testing all this out, I noticed that suddenly both the Mac and the printer are hit or miss with being able to detect or read the SD card. Perhaps the card is going bad. That doesn't explain why some of the older prints on it still work, but I'm trying to find another card to test out. 

  • Link to post
    Share on other sites

    Posted · Cura files crashing Marlin

    Haven't confirmed yet, but I think I found my answer here: 




    "...The cause is cards which do not have the capacity as shown on them.
    8GB capacity cards can actually be as little as 256MB capacity available.
    So when large files or a number of files are written the file is corrupted."


    If that's it, I wasted a lot of time and effort. Hopefully this gets crawled so somebody else can get a quicker solution than I did. 

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...