Jump to content
jck480

Weird additional retraction of second extruder

Recommended Posts

Posted · Weird additional retraction of second extruder

Hello all,

I just signed up because I am facing a strange problem I have not seen before and cannot find a solution for. Maybe you can point me in the right direction.

 

I own a Tronxy X5ST-2E with a single nozzle dual extruder - nothing special so far. The machine has some flaws like a lot of oozing/stringing which needs to be adressed, but that's another story...

 

So here's my problem: :D

I use my second extruder (T1) for PVA support and raft structures whilst the first extruder is printing pva, both with 1.75mm filament.

I did add some additional code to retract/extrude both filaments prior to starting the print to make sure both filaments are at the correct starting points and don't block each other as this as a Y shaped hotend with ~40mm "overlap" which needs to be avoided.

So far so good.

Now when slicing the print it includes my start gcode:

;FLAVOR:Marlin
;TIME:1243
;Filament used: 1.00906m, 0.606249m
;Layer height: 0.4
;MINX:156.841
;MINY:156.841
;MINZ:0.36
;MAXX:327.393
;MAXY:327.394
;MAXZ:81.66
;Generated with Cura_SteamEngine 4.6.0
T1
M140 S50
M105
M190 S50
M104 S200
M105
M109 S200
M82 ;absolute extrusion mode
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
T1
G1 F200 E-30
G92 E0
T0
G1 F200 E-30
G92 E0
G1 F200 E60
G92 E0
G1 F200 E-45
G92 E0
T1
G1 F200 E60
G92 E0

G92 E0
T1
G1 F200 E3
G92 E0
M83 ;relative extrusion mode
G1 F1500 E-6.5
;LAYER_COUNT:200
;LAYER:-5
M107
G0 F7200 X158.321 Y160.727 Z0.36
;TYPE:SUPPORT-INTERFACE

 

And perfectly prints the first layer.

After finishing the first layer it adds the following code:

G1 F3000 E-45
G1 F600 Z1.36
T0
M105
M109 S200
M106 S255
G1 F6000 E-10
G0 F7200 X172.8 Y167.491 Z1.36
G1 F600 Z0.36
G0 X172.8 Y167.491 Z0.96
G0 F7200 X172.674 Y162.775
;TIME_ELAPSED:40.696914
;LAYER:-4
M140 S50
G1 F3000 E-35
G1 F600 Z1.96
T1
M105
M109 S200
M107
G0 F7200 X172.674 Y162.775 Z1.96
;TYPE:SUPPORT
G1 F600 Z0.96
G1 F3000 E53.31503

As you can see above it basically does retract the support filament by 45mm, then switches to T0 (which is the model filament extruder), retracts 45mm model material and then switches back to the support material (T1), re-extruding the 45mm + additional needed material for priming...

 

In the further progess, when it comes to "really" switching to T0 (model material) it retracts the still active T1 by 45mm and extracts the defined 45mm of T0 (heat zone length = extruder switch amount) before continuing

G1 F1500 E-6.5
G0 F600 X157.128 Y162.404 Z2.06
G0 F7200 X168.829 Y172.669
G0 X305.877 Y305.877
;TIME_ELAPSED:187.621831
;LAYER:0
G1 F3000 E-38.5
G1 F600 Z3.06
T0
M105
M109 S200
M106 S255
;MESH:Konstruktion2.stl
G0 F3600 X305.877 Y305.877 Z3.06
;TYPE:PRIME-TOWER
G1 F600 Z2.06
G1 F3000 E45

How can I change this behaviour? I need, on the one hand to include a retract in my start code to prevent the model material from blocking the support material. And on the other hand I need to make sure the additional 45mm retract of model material after first support layer (which I assume should be the "pre-start" retraction at the wrong point?) is not performed or moved to the starting g-code.

 

Thanks a lot in advance for any suggestion.

Jan

Share this post


Link to post
Share on other sites
Posted · Weird additional retraction of second extruder

I am not sure on how to modify/edit a post so I will add some additional information in this reply.

 

After reading my post I think the problem is not exactly specified 😕

 

The weird thing is, that I have to do a manual retract (30-45mm) of the model material at the beginning to prevent it from blocking the support material. After the first layer it does an additional (unnecessary) retraction in the heat zone length. But when it comes to printing with model material it only pushes the 1x the heat zone length into the extruder which is not enough as he did an additional 45mm retract after the first layer.

So I need to get rid of the unnecessary retraction after layer one or make cura to move it to the start, so I can remove my own start gcode...

 

Thanks a lot

Jan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...