Jump to content

Can't Authorize to My S5 via REST API (Swagger UI)

Go to solution Solved by Hola_Adam,

Recommended Posts

Posted · Can't Authorize to My S5 via REST API (Swagger UI)

Hello, this is my first time delving into the API, and I'm struggling to even get authorized.


I've been interacting with my Ultimaker S5 (firmware 7.1.3) via the Swagger UI and I'm able to

  • POST /auth/request to get an ID + key pair after hitting 'Allow' on my printer
  • GET /auth/check with my ID which returns "authorized"

But then GET /auth/verify or GET /print_job/gcode just returns a 403 "Authorization required."



  • Link to post
    Share on other sites

    • Solution
    Posted · Can't Authorize to My S5 via REST API (Swagger UI)

    Issues has been solved--I had missed the browser pop-up when I first did GET /auth/verify and it doesn't pop up on subsequent attempts. I restarted my browser, then input my ID and Key in as the Username and Password an everything works now.

    • Like 2
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.3 stable released
        In this stable release, Cura 5.3 achieves yet another huge leap forward in 3D printing thanks to material interlocking! As well as introducing an expanded recommended print settings menu and lots of print quality improvements. Not to mention, a whole bunch of new printer profiles for non-UltiMaker printers!
          • Thanks
          • Like
        • 56 replies
      • UltiMaker Cura Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 34 replies
    • Create New...