Jump to content

All Cura versions suddenly crashing at start up - Windows

Recommended Posts

Posted · All Cura versions suddenly crashing at start up - Windows

Hi all, this morning went to open Cura only to find it crashing constantly at the start up splash screen. It has been working fine previously since I started using it around January.


Cura version(s tried): 5.3.1, 5.3.0, 5.2.2

Machine OS: Windows 11 (Unsure when the update snuck in- going to try to downgrade to 10 later today)


Steps tried:

  • Uninstall and reinstall cura
  • Run as administrator
  • Delete old data/versions
  • Disable network
  • Unplug external USB etc hardware
  • Run using NVIDIA driver

Currently looking for driver updates to see if it's an outdated one.


PC is not ASUS so don't have the ASUS GPU Tweaks option.


Is there anything else that could be worth a try? I've attached error logs just in case anyone has had similar issues.


Thanks in advance!


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.4 stable released
        The full stable release of UltiMaker Cura 5.4 is here and it makes it easier than ever to remove brims and supports from your finished prints. UltiMaker S series users can also look forward to print profiles for our newest UltiMaker PET CF composite material!
          • Like
        • 58 replies
    • Create New...