Jump to content
Sign in to follow this  
backsubzero

http://daid2.mine.nu/~daid/marlin_build/ error on build

Recommended Posts

Posted · http://daid2.mine.nu/~daid/marlin_build/ error on build

I try to build for arduino 328, I select in Hardware board type Duemilanove w/ATMega328 pin assignments and Arduino hardware Duemilanove w/ATMega328, but not work, and show this erros.

Build log

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/Sd2Card.cpp:20:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/stepper.cpp:24:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

Marlin/Marlin/stepper.cpp:822:1: error: pasting "DIO" and "-" does not give a valid preprocessing token

Marlin/Marlin/stepper.cpp:822:1: error: invalid suffix "_RPORT" on integer constant

Marlin/Marlin/stepper.cpp:822:1: error: pasting "DIO" and "-" does not give a valid preprocessing token

Marlin/Marlin/stepper.cpp:822:1: error: invalid suffix "_WPORT" on integer constant

Marlin/Marlin/stepper.cpp: In function 'void st_init()':

Marlin/Marlin/stepper.cpp:822:1: error: 'DIO' was not declared in this scope

Marlin/Marlin/stepper.cpp:827:1: error: 'DIO' was not declared in this scope

Marlin/Marlin/stepper.cpp:843:1: error: 'DIO' was not declared in this scope

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/SdBaseFile.cpp:21:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/SdVolume.cpp:20:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/SdFile.cpp:20:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/Marlin.cpp:30:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/temperature.cpp:32:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/MarlinSerial.cpp:23:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/cardreader.cpp:1:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/motion_control.cpp:22:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/planner.cpp:54:

Marlin/Marlin/pins.h:447:2: error: #error Oops! Make sure you have 'Arduino Duemilanove w/ ATMega328' selected from the 'Tools -> Boards' menu.

In file included from Marlin/Marlin/Marlin.h:26:0,

from Marlin/Marlin/SdFatUtil.cpp:20:

Share this post


Link to post
Share on other sites
Posted · http://daid2.mine.nu/~daid/marlin_build/ error on build

Changed a few things, but it's still not building for the Duemilanove. Not sure why. Note that the ATMega328 is too small to build Marlin with any SD or LCD option.

Share this post


Link to post
Share on other sites
Posted · http://daid2.mine.nu/~daid/marlin_build/ error on build

I disable in your form, but not work, I'm not need SD and LCD in my small machine...

Thanks for help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!