Jump to content
Ultimaker Community of 3D Printing Experts

Cura starts printing at 20mm above the heated bed of prusa i3

Recommended Posts

I am running Cura 15.04 on Lubuntu 16.04 with a Prusa i3:


I only set the number of extruder to 1, so I ran exclusively on the first extruder. Then I successfully ran the bed levelling wizard.

Then I loaded the sample ultimaker figure and pressed "print" The printing started after the bed and the nozzle warmed up, but on the first layer, the print head moved into the middle and 20mm above the heated bed. So needless to say, the filament failed to stick to the heated bed.

So where has gone wrong? The printer firmware, or the cura settings?

Share this post

Link to post
Share on other sites

Well in machine settings in Cura you have to set the maximum height of the printer. If you have that wrong that would cause your problem, i.e. at start up the bed will be raised to that position.


I don't understand. In "Machine settings", there are "max width", "max depth", and "max height"

Then it also have the options of head size towards X min/max, Y min/max and printer gantry height.

For the head size towards .... the description says "The head size when printing multiple objects, measured from the tip of the nozzle towards the outer part of the head" This confuses me, so how can I measure the Xmin and Xmax?

In this particular case, the printer gantry height is set by default to 0. Is this the cause of the problems?

In other software (such as MatterControl), the printer just starts at Z=0 (or 0.5 etc) and does not have this problem.

Share this post

Link to post
Share on other sites

Para 1. Yes those are your printer dimensions in terms of printable area. They are not standard so Cura needs to know your measurements so it can ensure you model is printable without going outside of you printable area, i.e. a cube in space. I was just suggesting that you double check your max height against your printer specification. If you spec is 200 and you entered 185 you would be 15mm short.

Para 2&3. These measurements are only relevant if you are printing more than one model. Firstly Cura needs to ensure that the models have enough space around them so that when it is printing one model the print head cannot touch another model. Now it is a long time ago but when I set my printer up I found this confusing because the help text says the same thing for the min. box and the max. box. I think I measured from the nozzle out to the outside edge of the fan and put that measurement into both boxes. This does not have to be accurate to 100 microns. I think I probably went 1 or 2 millimetres over the measurement to be sure. If you are printing multiple modes in "print one at a time" mode instead of "print all at once mode", Cura needs to ensure that after printing the first model there is enough height to print subsequent models without the gantry hitting the completed model(s).

Para 4. Erm, no I do not think so otherwise that would not be the Cura default. Indeed they all have 0 defaults so presumably the Cura default is that you are not printing multiple models. You may as well put in your measurement, in 2 months time you will print multiple models forgetting that you did not set it!

Para 5. Z=0 is not the same command as Z0.  Z0 moves the bed to the minimum end stop, i.e. your max height setting. Z=0 is an offset command; if it is z=0 then there is no offset and your bed would be moved to position 0. If you put in z=15 and then issued z0, the print bed would be positioned 15mm below  the nozzle. If it is set to 0 then it is irrelevant in terms of your problem. For example on my printer I do the bed levelling without the glass plate inserted. If I did nothing else then when the print is initiated the glass plate would smash into the nozzle. So I put in a z-offset command to compensate, so that the bed itself is positioned below the nozzle at a distance which equates to the height of the glass plate.

Ok in your first post you did not say anything about printing successfully with another slicer - I assumed you had set the printer up and your first print had failed.

My point is that you should check Cura's  max height setting to ensure it is correct for your printer. If it is not then that could easily be your problem. I cannot think of anything else that would cause your problem from within Cura, unless you have a duff z-offset command in the start gcode section.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 21 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!