Jump to content
Ultimaker Community of 3D Printing Experts
Right_There

Ultimaker 2 Heated bed is taking forever to heat.

Recommended Posts

The heated bed on my UM2 takes a long time to heat up. It is usually about 20 minutes to get to 95C, then an extra 10 minutes to get to 100C. It never surpasses 101 even after hours. I have heard that the early model printers, wich mine is, had loose build plate connector wires, I tried giving the wires a shake but it didn't help. Any thoughts would be greatly appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 15 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 18 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!