Jump to content
Ultimaker Community of 3D Printing Experts

Brand new Ultimaker 2+ won't turn on

Recommended Posts

Our office just acquired an ultimaker 2+. It worked perfectly on the first day, and our test print came out fine. However, when we plugged it in the next day, none of the lights came on, and all we got was a bit of noise on the main display (I've attached an image below). There were no changes made to the printer between the two days.

The only other info I could find online was this thread. I tried removing and reconnecting all the connectors on the main board as suggested, but unfortunately that didn't work for us.

Would anyone have any ideas on how to fix this?



Share this post

Link to post
Share on other sites

Weird, I have the same garbled screen when I turn on the printer, but it goes away and the printer works perfectly. I assumed it was just a harmless boot-display-firmware-glitch. I think it is the same for you but after the firmware goes to the next step in the boot-up process, it hits a problem and halts.

If it is not something else externally (bad wall socket, power supply, damaged power supply cable), then maybe the board died. Where did you buy the printer?

Share this post

Link to post
Share on other sites

thanks for your response,

I got the same screen the first time I switched it on too. But, like you said, it disappeared within a few seconds and worked normally.

The only thing I can think that I may have done wrong was to switch off the mains supply before switching off the device. I've checked the power supply, it seems alright. Nothing else on the board seems fried, and the green power LED lights up. In case of a firmware glitch, is there any way of re programming it to fix the problem?

I bought it from Local Makers in Amsterdam.

Share this post

Link to post
Share on other sites

^That worked....Thanks! I didn't think it would be so simple, but I guess it was a stupid mistake on my part.

For anyone else who runs into this issue - I had connected my PC to the ultimaker, when a powercut occurred, so I had to switch off the ultimaker to prevent it from draining the UPS. At some point prior to this I may have started upgrading the firmware without me realizing it, and switching off the machine must have corrupted the file that was loaded. Re-uploading the firmware fixed the problem.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 2 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!