Jump to content
Ultimaker Community of 3D Printing Experts

Can't Connect to Duet Controller


Recommended Posts

Posted (edited) · Can't Connect to Duet Controller

I've just installed a Duet controller into my Mini Kossel printer. I'm unable to connect to it using Cura over USB. I was able to connect to the Azteeg X3 that was in it previously. The error log I get is...

Changing monitoring state from 'Offline' to 'Opening serial port'

Connecting to: COM5 with baudrate: 115200 (configured)

Unexpected error while connecting to serial port: COM5 ValueError: 'Cannot configure port, some setting was wrong. Original message: [Error 121] The semaphore timeout period has expired.' @ machineCom.py:_monitor:332

Found no ports to try for auto detection

Changing monitoring state from 'Opening serial port' to 'Error: Failed to autodetect serial port.'

I'm able to connect to it fine using Simplify3D if I enable hardware flow control. Is there a setting for this in Cura?

Edited by Guest
  • Link to post
    Share on other sites
    Posted · Can't Connect to Duet Controller

    For whatever reason, I was finally able to connect to the Duet last night. I don't really think I changed anything. I just kept trying and it finally worked.

    However, there's still an issue. I was able to jog the printer just fine from Cura but when I tried to print something the hotend wouldn't move. I'd see the progress bar moving as if Cura thought it was sending data and it was being executed but there was never any movement from the printer. Strangely enough, I've been helping a friend who is building a Cartesian printer based on the RAMBo controller who is having the exact same issue (can jog but not print). We thought it was a printer issue but maybe its a Cura issue. Ideas?

    Thanks,

    Ian

  • Link to post
    Share on other sites
    Posted · Can't Connect to Duet Controller

     

    @nallath - Thanks for the reply. The RAMBo has probably been around and used in several (RepRap based) commercial printers longer than any. The 32-bit Duet is quickly taking off among builders. It would be worth getting one of each for your test lab. I'd be willing to bet you could get one of each donated if you made a request.

  • Link to post
    Share on other sites
    Posted · Can't Connect to Duet Controller

    There is a limited amount of time that we get to spend on non-um products and getting them to work in Cura (as it's still Ultimaker that pays me for my work, it's reasonable that they expect a strong focus on their / our products).

    But Cura is open source, so if people want to help, i'd love to answer questions / help out.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
          • Like
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 4 replies
    ×
    ×
    • Create New...