Jump to content
Sign in to follow this  
cyclone

Netfabb GCODE via Printrun/Pronterface

Recommended Posts

Posted · Netfabb GCODE via Printrun/Pronterface

I've noticed the latest Pronterface's new-ish time estimation algo barfs on Netfabb code.

It seems the offending line is:

G1 E0.0000

Is anyone aware of how to fix this in Netfabb as it seems to be a useless possibly malformed G1. (It would be nice

if Printrun did a little error checking of its input.) I'm sure Printrun expects an XYZ if there is anything.

Also It's part of the generated code and not something I can take out of the "Start" section of Machine. i

-b

Share this post


Link to post
Share on other sites
Posted · Netfabb GCODE via Printrun/Pronterface

"G1 E0.0000" is fine as GCode so it must be the Pronterface that cannot handle it correctly. You should file a bug at the github project, it will most likely get fixed then.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 23 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!