Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
3dtopo

Heated Bed not working with Ulticontroller enabled

Recommended Posts

So my heated bed has been working great:

http://www.thingiverse.com/thing:30655

But I just hooked up an Ulticontroller i just got, and enabled the Ulticontroller using Daid's excellent firmware builder at:

http://daid.eu/~daid/marlin_build/

And the heated bed no longer works (It was still configured for the heated bed). If I upload firmware without the Ulticontroller enabled the heated bed works.

Any suggestions would be greatly appreciated!

Share this post


Link to post
Share on other sites

I have the same issue earlier and I resort to download from github/ultimaker/marlin to build it manually. You need to uncomment the #define BED_LIMIT_SWITCHING or #define PIDTEMPBED depending on if you are using a relay or MOSFET to control your bed. Also, don't forget to uncomment the #define ULTICONTROLLER and TEMP_SENSOR_BED to enable the temperature monitoring.

Share this post


Link to post
Share on other sites

I can explain this for dummies

"I have the same issue earlier and I resort to download from github/ultimaker/marlin to build it manually. You need to uncomment the #define BED_LIMIT_SWITCHING or #define PIDTEMPBED depending on if you are using a relay or MOSFET to control your bed. Also, don't forget to uncomment the #define ULTICONTROLLER and TEMP_SENSOR_BED to enable the temperature monitoring."

I find github/ultimaker/marlin to build it manually.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!