Jump to content
Ultimaker Community of 3D Printing Experts
reweum

UM2+ reset

Recommended Posts

Verzeiht einem Newbie, wenn die Frage allzu simpel ist.

Habe einen UM2e+. Nach ersten Drucken (kleinen Gehäusen usw. bin ich schon mal voll begeistert.

Jetzt habe ich mir auf einem Raspi Octopi eingerichtet und slice mit Cura 15.04.6 und entsprechenden start/end.gcode.

Das klappt tadellos, solange ich nicht von der SD per Hand drucke. Den Grund hab ich nach einigen Tagen gefunden;-)

https://ultimaker.com/en/community/18191-howto-octoprint-raspberry-pi-2-und-um2-extended-mit-standard-firmware

Leider kann ich im Moment noch nicht ganz verhindern, dass ich hin und wieder von SD drucken muss, weil ich am Raspi noch rumbastle.

Nun suche ich eine einfache Möglichkeit, den UM zu ersetten, ohne jedes Mal die Grundeinstellungen mit dem Assistenten neu machen zu müssen.

Wie macht man das am Besten?

Share this post


Link to post
Share on other sites

Hi,

ich verstehe nicht was der Grund war - was meinst du damit?

Ich nutze einen UM2+ mit OctoPrint und drucke auch von SD. Dazu habe ich in Cura 15.x zwei Drucker angelegt. Einen mit UltiGcode (für SD) und einen mit normalem Gcode für OctoPrint.

Share this post


Link to post
Share on other sites

Danke für die Rückmeldung,

also das Problem ist so wie schon im Thread

https://ultimaker.com/en/community/18191-howto-octoprint-raspberry-pi-2-und-um2-extended-mit-standard-firmware

beschrieben.

Ich generiere mit Cura 15.x einen GCode im RepRap/Marlin Format. Dann lade ich den über das WebFrontend in Cura und drucke diesen aus.

Das klapp prima, sofern ich zuvor nicht von Hand per SD Karte gedruckt habe.

In dem Fall stimmt die Extrusion nicht (krasse under extrusion).

Dabei ist es offenbar egal, welches GCode Format ich von SD gedruckt gedruckt habe. Es kann sogar exact die gleiche Datei (RepRap/Marlin) sein! Es reicht, wenn von SD gedruckt wurde.

Erst wenn der UM2+ resettet wurde (Ausschalten reicht offenbar auch - wie ich grad probiert habe) klappt wieder alles normal.

Es ist also offenbar problematisch nacheinander von SD / Octprint zu drucken.

Mit dem Ausschalten zwischendurch kann ich ja leben. Man muss nur immer dran denken.

Und außerdem würde ich es gern verstehen. Rein mit dem "Gcode flavour" scheint es nicht zu tun zu haben. Wie gesagt, tritt bei mir auch auf, wenn ich eine RepRap/Marlin von SD und dann von Octoprint ausdrucken will.

Die Idee mit 2 Druckern in Cura ist sehr gut. Löst zwar nicht das Problem, vereinfacht aber den Test und Umgang mit beiden Formaten.

Im Moment teste ich das gerade, weil es mir vorkommt, dass sich die Ausdrucke je nach Format unterscheiden.

Ich habe festgestellt, dass in Cura beim UltiGcode-Format nicht alle Einstellungen zur verfügung stehen. Also neben den offensichtlichen - die ja per start./ende.gcode gemacht werden.

Aber auch der Flow wird bei UltiGcode offenbar von der Maschine gesteuert.

Wie gesagt mein UM2+ steht erst eine Woche hier rum;-) da ist mir vieles noch unklar, was sich hoffentlich bald in Luft auflöst;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!