Jump to content
dusan

Cura 2.3 A instead of E axis

Recommended Posts

Posted · Cura 2.3 A instead of E axis

My custom machine needs an A axis for extruding. I'm currently modifying the gcode file and replacing E's wit A's. Also I' replacing all M with ;M to comment all M codes. Any idea how to do this directly from Cura?

Share this post


Link to post
Share on other sites
Posted · Cura 2.3 A instead of E axis

Note, the MACH3 flavor did/does exactly this.

Share this post


Link to post
Share on other sites
Posted · Cura 2.3 A instead of E axis

While the Mach3 setting creates Gcode with the A axis for the print head the start and end code needs to be modified, see:

Preferences>configure curer>printers> click on the printer and then: machine settings>printer

 

Incidentally Mach 3 depreciates the use of G92. I wrote a Mach3 macro containing: DoOEMButton(142)    ' zero A

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!