Jump to content
Ultimaker Community of 3D Printing Experts
vpraplan

Cura 2.3.0 problem with custom profile

Recommended Posts

Hello everybody,

I'm facing a big issue with cura + custom profile and I hope somebody can help me understand what is happening.

We have 2 3D printers at work (Makerbot 2X and German Reprap X350 Pro) and we are printing a lot of parts with dual extrusion (material and support). I've discovered recently Cura software and for me it's really the best software I've tried so far.

I was using Cura version 2.3.0 Beta and except a small display issue, everything was working very nicely. I made a custom json profile for the X350 printer with dual extruder and I had very nice prints. Then I upgraded to v2.3.0 final and now it's impossible to use my custom profile anymore. I compared it to the new dual extrusion profile for the ultimaker3 and it seems very similar.

I think I narrowed down the issue to the dual extrusion parameter:

The profile is loading fine and I can add my custom printer in cura if I set the "machine_extruder_count" value to 1 in the json file. (but of course the slicing will fail) But if I set the "machine_extruder_count" value to 2 (as it should be) the profile loads fine and when I add the custom printer nothing happens, I don't even see the build area in Cura. I see that the custom printer was added, but I cannot select it. I tried adding an ultimaker3 printer and it works fine.

I dont understand what is happening and I cannot use cura anymore :( I even tried with the new V2.3.1 today, but still the same. (I'm working on windows 8.1 x64 )

Does anybody have an idea why this is happening ? You can find my custom json files here, I would be very interested to know if this behaviour can be reproduced.

Any suggestion will be much appreciated !

Share this post


Link to post
Share on other sites

Found the issue;

Change the meta data in left extruder to;

 

"metadata": {       "machine": "grr_x350",       "position": "0"   },

 

and in right extruder to

 

"metadata": {       "machine": "grr_x350",       "position": "1"   },

 

The mistake you made was not defining a position and not using the filename as an ID.

If you get this tweaked out, would you mind making a pull request so others can benefit from this?

Share this post


Link to post
Share on other sites

Thank you so much for your answer, the custom profile is working now !

I tried with and without defining a position for the extruder without any luck.

But my real mistake was to use a different ID and filename.

I changed and used the same ID/filename and now it's working perfectly, thanks again !!

I'm still tweaking the profile a bit, and when I think the quality is good enough I will make a pull request.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!