Jump to content
Ultimaker Community of 3D Printing Experts

Running Cura 2.3.1 on an older machine


doobes
 Share

Recommended Posts

Posted (edited) · Running Cura 2.3.1 on an older machine

All,

I've got a fairly old Dell Latitude D620 laptop running 64 bit Windows 10.

I would like to use this machine in my lab working with my printer.

Both the 32 bit and 64 bit versions of Cura give me this message upon startup:

"Could not initialize OpenGL.  The program requires OpenGL 2.0 or higher.  Please check your video card drivers."

The video card is listed as

Mobile Intel 945 Express Chipset Family

Any suggestions on how to get past this?

Thanks

Chris

Edited by Guest
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
          • Thanks
          • Like
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...