Jump to content
Ultimaker Community of 3D Printing Experts
Cerguei

UM3 extended no video

Recommended Posts

Can you dump the logs to USB stick to analyze?

Use System -> Maintenance -> Diagnostics -> Dump logs to USB to make this happen.

Check for messages about the mjpg-streamer starting (or failing to start).

If this service cannot be started, we'd like to know.

Share this post


Link to post
Share on other sites

Hi Marco,

Starting :

Logs begin at Wed 2017-03-29 20:49:48 CEST, end at Sat 2017-04-01 14:34:42 CEST. --

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: starting application

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: MJPG Streamer Version.: 2.0

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: Using V4L2 device.: /dev/video0

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: Desired Resolution: 800 x 600

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: Frames Per Second.: not limited

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: Format............: JPEG

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: TV-Norm...........: DEFAULT

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: www-folder-path...: disabled

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: HTTP TCP port.....: 8080

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: username:password.: disabled

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: commands..........: enabled

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: starting input plugin input_uvc.so

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: starting output plugin: output_http.so (ID: 00)

Jan 01 01:00:36 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: serving client: ::1

Jan 01 01:01:13 ultimakersystem-ccbdd30015e6 connmand[198]: ntp: time slew +1491049219.905818 s

Apr 01 14:21:32 ultimakersystem-ccbdd30015e6 systemd[1]: Time has been changed

 

Can you dump the logs to USB stick to analyze?

Use System -> Maintenance -> Diagnostics -> Dump logs to USB to make this happen.

Check for messages about the mjpg-streamer starting (or failing to start).

If this service cannot be started, we'd like to know.

 

Share this post


Link to post
Share on other sites

The line

 

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: HTTP TCP port.....: 8080

tells me that the streamer is listening to port 8080

Can it be a router/switch/firewall that prevents you from connecting to port 8080?

IF you can try to telnet to the machine on port 8080:

 

telnet  8080

 

it should return with

 

Trying ...Connected to .Escape character is '^]'

 

If it fails to connect:

 

Trying ...telnet: Unable to connect to remote host: Connection refused

 

In the latter case, something on you network is blocking access to port 8080 on the printer.

Share this post


Link to post
Share on other sites

Connecting to telnet OK :angry:

 

The line

 

Jan 01 01:00:35 ultimakersystem-ccbdd30015e6 mjpg-streamer[241]: MJPG-streamer [241]: HTTP TCP port.....: 8080

tells me that the streamer is listening to port 8080

Can it be a router/switch/firewall that prevents you from connecting to port 8080?

IF you can try to telnet to the machine on port 8080:

 

telnet  8080

 

it should return with

 

Trying ...Connected to .Escape character is '^]'

 

If it fails to connect:

 

Trying ...telnet: Unable to connect to remote host: Connection refused

 

In the latter case, something on you network is blocking access to port 8080 on the printer.

 

Share this post


Link to post
Share on other sites

Yes Marco, I really don't understand, don't work with two mac Cura 2.3 / 2.4 / 2.5 and app on iPhone. Perhaps cam HS...

Thx for your help

 

Telnet ok, but streaming from api or Cura isn't working.

That's really a strange one.

 

Share this post


Link to post
Share on other sites

No stream with http://:8080/?action=stream, white page, no error.

Where can I send you the log ?

Thx

Also, if you have just turned on your printer, is the stream accessible / working when using the API directly:

http://:8080/?action=stream

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy