Jump to content

Upgraded from 3.0.4 to 3.1.0 - Cura Freezes and Now Older Won't Even Work


Recommended Posts

Posted · Upgraded from 3.0.4 to 3.1.0 - Cura Freezes and Now Older Won't Even Work



I've been using Cura for months with no issues. I was on 3.0.4 and upgraded to 3.1.0 when the pop-up prompted me about a new version. All of the sudden, it freezes and becomes unresponsive when trying to run it. I'm on Windows 7, 64 bit. The splash screen will show up and then it freezes and says "not responding"; I have to manually kill it.


Uninstalling, then reinstalling does not work. However... If I uninstall with Revo Uninstall (to clean up leftover files), then it will work... once... and then starts freezing again. I've even tried to go back to older versions (2.5 and 2.7) and the same thing happens. I tried to just use Prusa Control instead, but now Prusa Control freezes also! The only slicer program that doesn't freeze for me is Slicer, but slicer gives me crappy results; Cura has always been the best.


I've even reinstalled Windows 7. That seemed to fix the issue, but then it started up again. This is driving me crazy. I can't work on my project because of this.


Does any anyone have any ideas? Thanks for any help offered.

  • Link to post
    Share on other sites

    • 1 month later...
    Posted · Upgraded from 3.0.4 to 3.1.0 - Cura Freezes and Now Older Won't Even Work

    Ok, here is the log file from my latest attempt just now. Please note, I just upgraded to Windows 10 and the issue still persists.


    Please see the attached log file.




  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...