Jump to content
Ultimaker Community of 3D Printing Experts
chhu79

File size limit on STL files?

Recommended Posts

Just tried to slice a dual color print and cura 3.1 gets stuck on Slice... (disabled auto-slice, hit Prepare button), nothing happens anymore. I use Linux RHEL7, The STL files are 1.1GB / 560MB. Windows version tells me invalid files, Linux opens everything just fine but I noticed that I cannot save anything (leads to zero-files). I hope there is no limit in place? My machine has plenty of RAM and the console output says nothing unusual. When I go to lower res everything works. (I actually want to go to higher res...) See image attached.

Thanks,
Chris

Screenshot.thumb.png.474df5ed5d099c28d706ed73cc377132.png

Share this post


Link to post
Share on other sites

I have sliced 2+ GB files. Takes a while though.

 

Also, what OS version and chip? 32 or 64 bit?

 

Is there a link to the file so that others can try?

 

Also, different OS's (and versions) have issues with file types based on how strict it can be about versions of the files generated. File types are not all that much the 'same' as people would like to think.

Edited by kmanstudios

Share this post


Link to post
Share on other sites

OK, I took a look at the files you made available. It was a bit on the huge side by way of poly count, but also a bit on the tiny side by scale. When I did get it to import, it was automatically scaled up 10,000%. So, not sure how the model got so tiny.

 

But, I scaled it up in a different package and then reduced the poly count because it was way more definition than Cura would have used.

 

You can get the files I made here. I did break it into 3 models instead of two. Stand, Water and Land masses.

 

I am not sure, but I do think you ran into a size limit after all.

Share this post


Link to post
Share on other sites

Thanks! How did you decimate the mesh? I do intend to go for higher res, as the UM3 is able to print this kind of detail, but mesh reduction for smooth areas cannot hurt. I found that meshlab has poor options and introduces problems and Meshmixer only runs on windows... I suspect the problem is with Cura, as CuraEngine is pure C++ and should not be limited by file / mesh size. I do not see CuraEngine starting. Maybe a Cura developer can comment on that?

The meshes come from a python script that combines a refined icosahedron mesh with a DEM GeoTiff. The dual coloring is a bit more complex. The stand is just combined mesh quickly sketched from openscad. The globes have an average radius of 1, that is why they are so small, but it allows for accurate scales. Put it on 6750% (67.5cm) and you have an 1:1.000.000 Earth.

 

Share this post


Link to post
Share on other sites

Glad it worked for you. I used 3D Coat to do the optimization. First I converted to Voxels and then out as an OBJ and the run through 3DSMAX to check it and further weld things. You have to remember that what happens when things get sliced, you fall victim to the Nyquist Frequency, only in reverse. Although the printer can do certain things, it is still subject to sampling rules. Even the version I sent to you got sub-sampled when sliced and it was already optimized. There is a point where perfection and accuracy is lost to human senses because even if we could tell micrometers of detail, without a true comparison, there is not any way to discern this. That is why I try to work within certain 'artistic' parameters, even with a hip machine like the UM3E.

 

3DCoat would have sufficed. I just have a version of MAX that I can use from a few versions back. Nice to have a double check. The version I sent out is not at the same scale as that created real issues both programs. That was micromesh for sure.

 

Is this a proprietary model? I played with it in my own Cura to make sure it would slice ok and would like to print it if it is not proprietary or paid for.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!