Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
olivierc

"Something went wrong during slicing"

Recommended Posts

Help me Daid or anyone!

I'm trying to slice a model in Cura, a big one for a big print, but after about an hour of calculation, I get an error message saying something went wrong during slicing, and the model has disappeared. I tried twice and it happened both times.

My model is very clean I think, I spent a lot of time doing all kind of check to make sure everything is closed, merged and fully manifold.

Here is the log. I can see the last line says Memory Error. Does that mean I ran out of RAM? because I still had plenty, I sliced this at work where I have 12 gig of memory, on powerful. The model is "only" 200000 poly. Sure it's a lot, but it's already optimized and necessary for the sculpture I want to print. I have sliced models with more polygons that this before, but they where not as big in term of volume.

Maybe I'm missing something form the log, some operation that might have generated this memory error, like a division by zero or something. If someone want to take a look at the model itself, I can post it.

I'm using version 13.04, not the beta. I have sliced many models in cura, some more complex, this is the first time this happens to me.

 


0.00: 0 Missing default setting for: 'extruder_offset_x0'
0.00: 0.0 Missing default setting for: 'extruder_offset_y0'
0.02: 0.0
4.33: File E:\upperbody.obj is being chain exported.
1251.52: Carve procedure took 20 minutes 24 seconds (26282586).
1477.56: Preface procedure took 4 minutes 13 seconds (125350399).
2908.04: Inset procedure took 23 minutes 43 seconds (122885135).
5310.09: Warning, deltaX in addSegmentToPixelTable in euclidean is 0.
5310.09: (1289.30416757+41.1167303976j)
5310.09: (1289.30416757+41.1167303976j)
5310.09: 0
5310.09: 0
5310.34: 0.097284
5310.34: Warning, deltaX in addSegmentToPixelTable in euclidean is 0.
5310.34: (1289.30416757+41.1167303976j)
5310.34: (1289.30416757+41.1167303976j)
5310.34: 0
5310.34: 0
5310.34: 0.097284
5310.34: Warning, deltaX in addValueSegmentToPixelTable in euclidean is 0.
5310.34: (1289.30416757+41.1167303976j)
5310.34: 1
5310.34: (1289.30416757+41.1167303976j)
5310.34: 0.097284
5310.34: Warning, deltaX in addSegmentToPixelTable in euclidean is 0.
5310.34: (1289.30416757+41.1167303976j)
5310.34: (1289.30416757+41.1167303976j)
5310.34: 0
5310.34: 0
5311.11: 0.097284
5311.11: Warning, deltaX in addSegmentToPixelTable in euclidean is 0.
5311.11: (1289.30416757+41.1167303976j)
5311.11: (1289.30416757+41.1167303976j)
5311.11: 0
5311.11: 0
5311.54: 0.097284
Traceback (most recent call last):
File "app_main.py", line 51, in run_toplevel
File "C:\Program Files (x86)\Cura_13.04\pypy\lib-python\2.7\runpy.py", line 162, in _run_module_as_main
"__main__", fname, loader, pkg_name)
File "C:\Program Files (x86)\Cura_13.04\pypy\lib-python\2.7\runpy.py", line 72, in _run_code
exec code in run_globals
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\__main__.py", line 216, in <module>
main()
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\__main__.py", line 85, in main
output.append(export.getOutput(filename))
File "Cura\slice\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\export.py", line 269, in getOutput
gcodeText = skeinforge_craft.getChainTextFromProcedures(fileName, procedures[: -1], gcodeText)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\skeinforge_application\skeinforge_utilities\skeinforge_craft.py", line 42, in getChainTextFromProcedures
text = craftModule.getCraftedText(fileName, text)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\fill.py", line 415, in getCraftedText
return getCraftedTextFromText( archive.getTextIfEmpty(fileName, gcodeText), repository )
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\fill.py", line 425, in getCraftedTextFromText
return FillSkein().getCraftedGcode( repository, gcodeText )
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\fill.py", line 1158, in getCraftedGcode
self.addFill(layerIndex)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\fill.py", line 952, in addFill
self.addThreadsBridgeLayer(layerIndex, nestedRings, rotatedLayer)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\fill.py", line 1097, in addThreadsBridgeLayer
euclidean.addToThreadsRemove(extrusionHalfWidth, nestedRings, self.oldOrderedLocation, self, threadSequence)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\fabmetheus_utilities\euclidean.py", line 219, in addToThreadsRemove
getTransferClosestNestedRing(extrusionHalfWidth, nestedRings, oldOrderedLocation, skein, threadSequence)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\fabmetheus_utilities\euclidean.py", line 1630, in getTransferClosestNestedRing
closestNestedRing.addToThreads(extrusionHalfWidth, oldOrderedLocation, skein, threadSequence)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\fabmetheus_utilities\euclidean.py", line 2276, in addToThreads
threadFunctionDictionary[threadType](extrusionHalfWidth, oldOrderedLocation, skein, threadSequence)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\fabmetheus_utilities\euclidean.py", line 2254, in addPerimeterInner
addToThreadsFromLoop(extrusionHalfWidth, 'edge', self.loop[:], oldOrderedLocation, skein)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\fabmetheus_utilities\euclidean.py", line 213, in addToThreadsFromLoop
skein.addGcodeFromThreadZ(loop + [loop[0]], oldOrderedLocation.z)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\skeinforge_application\skeinforge_plugins\craft_plugins\fill.py", line 956, in addGcodeFromThreadZ
self.distanceFeedRate.addGcodeFromThreadZ( thread, z )
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\fabmetheus_utilities\gcodec.py", line 305, in addGcodeFromThreadZ
self.addGcodeMovementZ(point, z)
File "C:\Program Files (x86)\Cura_13.04\Cura\slice\cura_sf\fabmetheus_utilities\gcodec.py", line 310, in addGcodeMovementZ
self.output.write(self.getLinearGcodeMovement(point, z) + '\n')
MemoryError

 

Share this post


Link to post
Share on other sites

It's a 32bit application, which means it runs out of memory after consuming 2GB of memory. (The amount of memory is not only related to the amount of polygons, but also to the internal volume of the model)

Checkout the Cura BETA thread, it contains a link to the 13.05 testing versions, these are much more suited to slice large models. I've sliced things up to 3000 layers on 500k polygon models without issues.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 27 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!