Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
nsa666

How to change default behavior of print button on Cura 13.06

Recommended Posts

i think i found the bug.

in machineCom.py line 30:

 


try:
key=_winreg.OpenKey(_winreg.HKEY_LOCAL_MACHINE,"HARDWARE\\DEVICEMAP\\SERIALCOMM")
i=0
while True:
values = _winreg.EnumValue(key, i)
if not forAutoDetect or 'USBSER' in values[0]:
baselist+=[values[1]]
i+=1
except:

the reg key looks like:

com-portsjksyv.png

The forAutoDetect is True and 'USBSER' is false. The list remains empty. The detection fails. Removing the "not" in front of forAutoDetect seems to help. but i don't know what side effects it has.

 

Share this post


Link to post
Share on other sites

Ah, look, there is the issue. The auto-detection-serial code assumes that you have an USB-serial device. Apparently Melzi electronics is using a different driver.

However, I knew this would happen. There is no real issue here, except that you manually need to configure the proper serial port in the preferences, then the auto-detection checks for that serial port instead of finding an USB-Serial device.

(Note, I have a plan to improve none-Ultimaker support. But I have to do that mostly in my free time. There are a lot of RepRap variations, and the first one I will look at will be the PrintrBot, as I can easy access one)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

[[Template core/front/global/_customFooter does not exist. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!